Title Language

  • 1
  • Question
  • Updated 4 months ago
  • Answered
Hello everyone.

Lately I got some problem with some Titles Language.

I'm from Kosovo and our native Language is Albanian. But somehow some Titles show in Serbian Language, mostly Foreign Films, but also some films like Inglourious Basterds, In the Name of the Father, Paris, Texas, etc.

In Site Preferences, I set Title display country = United States, and Title display language = English, but still same issues.
Photo of Migjen Toska

Migjen Toska

  • 283 Posts
  • 266 Reply Likes

Posted 1 year ago

  • 1
Photo of gromit82

gromit82, Champion

  • 6991 Posts
  • 8281 Reply Likes
Migjen: It seems that relatively few non-Albanian-language films have Albanian titles listed in IMDb. Thus, if you request the Albanian (country) titles or Albanian-language titles, you usually won't be provided with them since IMDb doesn't have them. (I didn't see Kosovo as a country in the Title Display Country menu.)

I do not know why Serbian-language titles are showing up for you instead. But I suggest setting your Site Preferences at https://www.imdb.com/preferences/general to Title Display Country = Original. That way, you will see the titles of English-language films in English, French-language films in French, German-language films in German, etc. The only films whose titles you will see in Serbian will be Serbian-language films and the only films whose titles you will see in Albanian will be Albanian-language films.
Photo of Migjen Toska

Migjen Toska

  • 283 Posts
  • 266 Reply Likes
I don't want to be in Albanian. I want to be in English. For example: Movie The Bandit (1996) is on English Title, Below is Eskiya in Turkish.

While: Kao zvezde na zemlji (2007) show Title in Serbian, Below in Indian (Taare Zameen Par)

So, I want all titles to be on English. Kao zvezde na zemlji (2007) to be Like Stars on Earth (2007).
Photo of Col Needham

Col Needham, Official Rep

  • 6834 Posts
  • 4809 Reply Likes
Sorry for the inconvenience.  This is a known issue and it is tricky to provide the best experience due to the way we store some of the information about original titles and local titles. 

Until we have a full solution, our recommendation (per gromit82's advice) is to go to your site settings at https://www.imdb.com/preferences/general and on the menu "Title display country" please choose "Original" which is the first item on the menu.  This will block the localization of titles which should improve things, even though there will still be some issues.
Photo of Robin

Robin

  • 7 Posts
  • 4 Reply Likes
This issue is known for at least five years.
Photo of Jurij Fedorov

Jurij Fedorov

  • 11 Posts
  • 5 Reply Likes
Yes, I have had this issue as long as I can remember. It never went away on any PC during my 14 years here. Weird that it is so hard to fix, but I'm not a programmer and for all I know it may require some big restructuring.
Photo of Robin

Robin

  • 7 Posts
  • 4 Reply Likes
I have Netherlands as my country and some titles give the Dutch title, but others still give the original title, while Netherlands is available. How come?
Photo of Vincent Fournols

Vincent Fournols

  • 2901 Posts
  • 4847 Reply Likes
Hi Robin,

Without prejudice of expert or IMDb staff feedback, have you notice whether this issue happen with "old" movies? I think I remember that when the system was upgraded about 18 months ago, there were a bunch some minor issues and all the functions were not deployed across all the database content. Probably, sharing the title would help to solve the situation, but maybe on a case by case basis.

Anyway, please share a sample of these findings so we can gather several advices.

This conversation is no longer open for comments or replies.