Ion Plunge has no sound

The audio stopped working on my ion plunge after 1 month. It connects, all the controls work but no sound. It doesnt even say "power on" or "bluetooth connected" anymore. I have tried to disconnect and reconnect but nothing works
6 people have
this problem
+1
Reply
  • Hi Eric,

    Thanks for posting. Sorry you're having issues with your Plunge.

    It sounds like your product may need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the ION Audio Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Mine has never spoken. The only noise I think I could get out of it is if I threw it against the wall. Going back to Amazon so we can get a real speaker that works and does what the McGrath says it will do. It doesn’t help that the answer to every question is “Submit a warranty or Service inquiry with....”
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited