Spooky behavior with Block Rocker

My Block Rocker (original, not Bluetooth) will often clip high/loud parts of music, both in the mic and aux inputs, and it seems to be getting worse — I can't push the inputs' volumes above the 2nd or 3rd lines now.

And sometimes, it won't play either of the inputs at all (nor will it play radio at those times). Turning it off and on doesn't seem to affect it, neither does unplugging then plugging it back in. Sometimes it just happens to work again. I checked the wiring behind the faceplate and it all looks and feels in order.

If I had to guess, it'd be something janky with the signal processor. Any ideas?
1 person has
this problem
+1
Reply
  • Hi Patrick,

    Thanks for posting. It sounds like your product may need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the ION Audio Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited