Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I've got the HTD Lync 12 connected with HTD's GW-SL1 RS232 to IP gateway, but I can't seem to get any of my commands to work. HTD's Valet app works just fine though. I noticed in HTD's Valet app (which is iRule), they have a special gateway defined as "HDT RS232". Could this be the issue? Or is the HTD iRule module required perhaps?

I've tried adding just a standard network gateway running on port 80 and 8000 (port scan shows only 80 and 8000 listening). I've also tried specifying the gateway as an GlobalCache RS232 to IP with no luck.
1 person has
this problem
+1
Reply
  • That has me intrigued... I have the HTD working fine with iRule. Unfortunately I bought the module before working through the commands on my handset so can't remember if it was the purchase of the module that triggered the ability to set up the gateway... but it's set up now (which I'm afraid isn't much help - if you're still struggling maybe try emailing iRule support directly?). Note that I don't use the module now as it was easier to either launch the HTD app. from iRule or use the device codes directly within iRule...) The module just gives you a page like the HTD Valet app. I attach screen shots of my iRule gateway configuration - hopefully they will help.





    To launch the HTD module from iRule (it took me a while to find it...)
    from an ipod/iphone/pad com.url=htd.valethomecontrol://
    from Android url=com.htd.activity

    Post again if you're still having problems and I'll see if I can dig into it further. But at least you know the GW-SL1 can work with iRule...
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Wow that's a lot of gateways haha. But yeah that HTD gateway is missing from my options and none of the other options seem to work. Sure does seem like that'd be something installed with the optional HTD module unfortunately. I'll try contacting iRule support directly to get their input.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • It's enough gateways to keep me occupied!
    I've transferred the licence between handsets and it seems that once the gateway is set up it persists even if the HTD module is no longer license to the handset. So it really should be something they can sort out for you.
    Once you're up and running let me know how you get on with the control. My Lync12 system works well - I'm really pleased with it. The only things I'm really missing are simple 'volume up' and 'volume down' commands. The slider works OK, but sometimes I just want to go up or down one or two steps and either my fingers are too big or my phone is too small...
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Hi Derek,

    The HTD Lync 12 is listed as an RS232 compatible device, so it should work. Since the Valet app works, your cabling an RS232 parameters are apparently correct.

    In the Valet App, you should be able to see and set the GW-SL1's IP address. You want to take the time to setup the GW with a STATIC IP now. This will save you alot of trouble later, when DHCP in your router decides to move your GW to a different IP, and iRule can no longer find it.

    Once you know the GW's IP, setup the iRule Gateway in the iRule App. Try the ITACH RS232 Gateway.

    1. In the Gateways Panel, click the blue 'Edit' in the upper right corner.

    2. Under ITACH RS232, click 'Add new gateway'.

    3. Click 'Add New Gateway' again. Or iRule may find it for you.

    4. Change the Name from 'New Gateway' to something you will know later, like 'Lync 12 Gateway'.

    5. Enter the IP address of the GW.

    6. Click 'Connect Devices'.

    7. Click 'Add Device'.

    8. Select the HTD Lync 12 Device.

    9. Click the blue '+' in the upper right corner.

    10. Click the blue '< New Gateway' in the upper left corner.

    11. Click the blue 'Save' in the upper right corner.


    If that doesn't work, you could try an HTTP Gateway. I say this because Port 80 is listening, which is normally HTTP. You could also try Port 8000, since it is also listening. For the HTTP Method, try all 3, Get, Post, and Put. Follow basically the same steps as for the ITACH RS232 Gateway. You may have to also supply a Username and Password, check the GW documentation.

    There is a little icon in the lower left corner when you are displaying Panels. If the icon is green, it should be good. Tap it for more info.

    You may also want to email support@iruleathome.com and ask them how to set up the Gateway. They respond to emails fairly quick, and they may be able to eliminate some of the trial and error.

    Hope this helps!

    Mike
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • 1. Add Network Gateway
    2. Input your GW-SL1's IP address
    3. Set Port to: 10006
    4. Set Protocol to: TCP
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • That seems to work for me! Many thanks.
    Next step how to get the GW-SL1 to a fixed IP address (my router's DHCP service doesn't do a look up on the MAC address, so the GW-SL1 changes IP address from time to time when there is a power outage).
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Guys, i treid everything you listed above.

    I have Lync 12 and a GW-SL1. I Firced my ip on the router to 192.168.1.2

    The best luck i had is setting the Gateway to Network, Port 8 and protocol to TCP.

    At least this make the signal turn green on my Valet Home app on my Google Pixel II.

    No commands to my system even appear to work much less work.

    I have replaced the cable with another one that goes from the GW-SL1 to the back of my Lync system but get the same lack of results..

    Help? I begging you guys!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • I have the gateway set up as shown - and then a sample command from the device...
    Works OK on my iOs devices. I think it was fine on my Android device (but am not able to check at the moment...)


    And just to check - after plugging in the GW-SL1 to the Lync. controller you dd then do a reboot on the controller & amp(s)?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Check the network connection. Open a command prompt on your computer, and enter the command "ping 192.168.1.xxx", where xxx is the last number in the ip address of the GW-SL1. If you can ping the GW, then you have the correct ip address. If the 4 tries time out, then the network is not set up correctly.

    EVERYTHING on your network has to have the same first 3 numbers in the ip address, in this case, 192.168.1. If they are not the same, the devices won't talk to each other. Your Subnet Mask should be 255.255.255.000.

    If you can log in to your router, you should be able to find some sort of map or list of the nodes on your network. With a little investigation, you should be able to determine if the GW-SL1 is connected.

    On the iRule app, there should be a green icon in the lower right corner if all the Gateways are good. Tap the icon to open a drawer on the bottom with more info. If the gateway is working there should be green arrows that flash when you tap a button.

    Let me know if you make any progress,

    Mike
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned