Help get this topic noticed by sharing it on Twitter, Facebook, or email.

New Android tablet not compatible. No v4.5 APK on download page...

I've just bought a new tablet specifically to use with iRule only to discover that according to Google Play Store "your device isn't compatible with this version". The tablet is an IRULU eXpo X1S although Google Play reports is as an Allwinner X181.

I thought I could install and side load v4.5 from http://getirule.com/support/downloads/ however the most recent version is 4.3.2 (which I've installed for now).

So could this tablet be made compatible with the Play Store and/or please post a download link to the 4.5 APK.

Thanks,
Graham
1 person has
this problem
+1
Reply