Asus Fn+F2 wifi/bluetooth toggle doesn't work on 1005HA

  • Question
  • Updated 4 years ago
The Asus fn key combo to toggle wireless connections (wifi and bluetooth) doesn't seem to work on my 1005HA. If I open Bluetooth preferences and select the eeepc bluetooth killswitch and then proceed to use the key combo fn+F2, it works as first to turn off my wifi. But then, I can't use the toggle to turn wifi back on. I have to deselect the killswitch option and restart the computer to get wifi to come back on.

Am I: a) misunderstanding how the killswitch option works (i.e. is it *just* a killswitch and not an on/off toggle?), or b) missing a driver to make this work properly?
Photo of

  • 10 Posts
  • 2 Likes
  • mildly frustrated

Posted 6 years ago

  • 7
Photo of

  • 1 Post
  • 0 Likes
Same problem here. 1005HA and fn+f2 or audio controls fn+f10, f11 or f12 wont work.
Photo of Supek

Supek

  • 3 Posts
  • 0 Likes
Same here. Is there other way to trigger bluetooth?
Photo of Cedric DUCLOS

Cedric DUCLOS, Official Rep

  • 1295 Posts
  • 112 Likes
Hi,

Bluetooth: you have the Blueman applet. With a right-click on it, you can turn Bluetooth on/off.

Wifi: you have the NetworkManager applet. With a right-click on it, you can enable Wireless (or not).

Sound: you have the Volume applet...

All these applets are in the top-right corner.
Photo of

  • 1 Post
  • 0 Likes
Right-clicking the network manager applet won't help. The option to enable wireless networking is greyed out and inaccessible.
I have to boot into Windows, enable Wifi via Fn+F2, and reboot again into Jolicloud. Then it works just fine.
Photo of cristobal.suazo

cristobal.suazo

  • 5 Posts
  • 0 Likes
I just installed JuliCloud on my Eee PC 1000HE but when runing the buttons Fn + F2 to manage my wireless card and bluetooth the computer freezes.
Photo of rashiedR

rashied

  • 9 Posts
  • 1 Like
it works on the eeepc 1000 with the pre-beta release, Fn buttons f10, f11 f12 and even f2 work fine
Photo of Sabin Densmore

Sabin Densmore

  • 1 Post
  • 0 Likes
Same Fn issues here with 1005HA. What's the solution, here? Sure, we can move the mouse to the upper-right and use the applets, natch. However, it should be a goal of a new OS to replicate/improve the behavior that already exists under a previous OS.
Photo of Zak Kaufman

Zak Kaufman, Employee

  • 4636 Posts
  • 376 Likes
Fn keys need to be implemented on some machines still.
Photo of pilipovetsP

pilipovets

  • 1 Post
  • 0 Likes
Hi,
I'm afraid I don't have Blueman applet as an icon in top right corner (is that what Cedric mean?). It is selected as an autorun application though. So how I can use bluetooth then? (ASUS 1101HA)
Thanks.
Photo of Ivan Ivanov

Ivan Ivanov

  • 8 Posts
  • 0 Likes
I have the same issue on 1101HA, it does not work out of the box like under ubuntu, you can maybe get it working with the eee-control ( http://greg.geekmind.org/eee-control/ ) but with some changes
Photo of Cedric DUCLOS

Cedric DUCLOS, Official Rep

  • 1295 Posts
  • 112 Likes
If you have a hardware switch on your device, make sure it's ON.
If Bluetooth is mentionned in BIOS, make sure it's ON.
Photo of Austin Ml

Austin Ml

  • 2 Posts
  • 0 Likes
SOLITON: fn+f2 tienes que habilitarlo en la BIOS en la opcion WLAN. Saludos
Photo of Austin Ml

Austin Ml

  • 2 Posts
  • 0 Likes
SOLUTION: fn + f2PROBLEMA resolved. must enable the BIOS option in the WLAN. regards