I’m frustrated

Dropbox keeps losing the location of its folder.

I'm using an Asus Eee PC 901. The OS is installed on the 4GB main file system. The 8GB media disc is being used to host my Dropbox files.

However, each time I log-in to Jolicloud, Dropox cannot find /media/disc/Dropbox where my Dropbox folders are. It then gives me the option of moving my files or relinking my account. However, the files are there!!
3 people have
this problem
+1
Reply
  • I had this problem too...

    The way I managed to solve the problem was to make an ext4 partition to the media disk (actually I formatted the whole disk), copy the home directory and its subdirectories as a root to the new partition and then mount that partition as /home.

    Google directions for moving /home to another partition on Ubuntu. Also google how to edit fstab if you're not familiar with it.

    This way Dropbox can have its folders within your home directory and that directory is sure to get mounted before Dropbox tries to access it.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly

  • If it works, it works, but it's true, be advised that editing fstab is one of the easiest ways to destroy a Linux installation.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly

  • Follow the instructions from here:

    http://www.psychocats.net/ubuntu/sepa...

    They are for regular ubuntu, but the same tools should be available in Jolicloud.

    The procedure goes basically like this:

    1. Make the new partition / format the media drive using Administration -> Partition Editor.

    Please note that formatting the drive will erase all files on the drive and resizing old partition and adding new one can do so also if there is a hick up. So backup everything valuable first.

    I made an ext4 partition, since Jolicloud seems to be using it on the main installation disk also.

    Take note of the Partition id (/dev/sda1 kind of thing...)

    2. Mount the new partition as what ever directory you wish and copy /home to it

    The article is old and uses ext3 -partitions in the example, so replace ext3 with ext4 and the partition id with the partition id from your machine.

    3. Rename the old /home and mount the new partition as /home

    This gives you an opportunity to test that everything still works

    4. Edit /etc/fstab to make mounting of the new /home partition happen whe booting up the computer

    When editing fstab the line should be something like:
    /dev/hda5 /home ext4 relatime,nodev,nosuid 0 0 instead what the article says (once again replace /dev/hda5 with the correct partition id)

    There's a good article on fstab: http://ubuntuforums.org/showthread.ph... (don't install the pysdm, it didn't work like it should...)

    5. Reboot

    If everything works you can free up space on the installation disk by deleting the old home directory
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly

  • I’m frustrated.
    I have this same problem.

    On the netbook (eeePC 701 SD) I created the dropbox folder in my 8GB SDHC card (/media/Volume(vfat)/Dropbox) rather than in the default location /home/jeff/Dropbox.

    If I run dropbox after startup (dropbox start from a command line), it finds the folder on the SDHC card, no problem.

    But if I set Dropbox to start on boot, it looks for the default location, doesn't find it, so I have to relink with the Dropbox folder on the SDHC card. This means entering my email address and password, skipping the tutorial, and telling Dropbox where the folder is. I think you will agree this is a major hassle.

    The problem is that the SDHC card is not mounted fast enough - the SDHC card is not ready by the time Dropbox tries to look for the Dropbox folder, and as such thinks it has been deleted.

    How can either:

    - the SDHC be mounted earlier in the boot sequence?

    or

    - the Dropbox application be delayed so that it starts after the SDHC card is mounted?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly

  • I’m delayed 30 seconds.
    I got some advice from "N.N." on the Dropbox forum:

    "Sounds like the SDHC card is not mounted at boot, but at login, after Dropbox has already started. This means that the SDHC card is not ready by the time Dropbox tries to look for the Dropbox folder, and as such thinks it has been deleted.
    You can work around/fix this in three ways:

    1. Change it so that the SHDC card is mounted at boot. By far the best solution. Easiest done by editing the /etc/fstab file, and adding a line for the SDHC card there. (Or removing the "noauto" part, if it's already listed.) This, however, requires some knowledge of the file, and how to edit it. I recommend reading the manual for the file, which you can do by either searching the web or by typing man fstab in the terminal.

    2. Add a wait to the Dropbox startup, so that it won't actually start the Dropbox executable until after the SHDC card should be mounted. Do this by editing the "~/.dropbox-dist/dropboxd" file, and adding a "sleep 5" (might need to up it a bit) one the line before the "dropbox" call.

    3. Start the Dropbox client manually, after the SHDC card is mounted."

    Well, I can confirm that Solution 3 works.

    I put a "sleep 30" in the dropboxd script, and sometimes it works, sometimes not.

    As for Solution 1, I really don't know what to enter into fstab, so I won't risk it.

    Any other solutions?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly

  • I’m delayed 45s
    The Final Solution:

    I created a script file in my home directory called dropboxdelay:

    #!/bin/sh
    # Delayed startup for Dropbox
    sleep 45s
    dropbox start

    I made the file executable, then I edited the command line in Startup Applications. It was

    dropbox start -i

    I changed it to

    /home/jeff/dropboxdelay

    and it works!

    You might be able to shorten the delay to the minimum that allows the card to get mounted at startup.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly