Why can't I change my screen's brightness?

  • Question
  • Updated 2 years ago
  • Answered
I have the latest Jolicloud alpha installed on my Dell Mini 9. It works admirably well out of the box, but one major annoyance I've discovered is that the brightness control doesn't work correctly.

If I use the netbook's brightness hot keys, it correctly displays the brightness meter bar and looks as if it's trying to change the setting, but it will always bump it back to what it was to begin with (around 80-90% brightness). It seems like something is telling the brightness meter to always return to a certain spot regardless of user input.

I love Jolicloud, but this problem is wreaking havoc on my battery life and may be cause for an uninstall if not resolved soon. Any help you could provide would be greatly appreciated!
Photo of Tyler Sticka

Tyler Sticka

  • 2 Posts
  • 0 Likes
  • frustrated

Posted 6 years ago

  • 5
Photo of Adam McDaniel

Adam McDaniel, Lead OS Architect

  • 228 Posts
  • 47 Likes
Hello,

Sorry for the delay in catching your question. Can you verify if this is still an issue after installing all system updates to your Mini 9, and reboot?

Thx
Photo of Tyler Sticka

Tyler Sticka

  • 2 Posts
  • 0 Likes
After this issue remained unresolved, I ended up ditching Jolicloud for a while. When the pre-beta release came out, I decided to give it another go, and was thrilled to see this (and a few other quirks) have been attended to.

I'm now happy to have Jolicloud and brightness controll on the same machine.
Photo of sonisausS

sonisaus

  • 9 Posts
  • 0 Likes
Adam,

It seems that couple of hotkeys are not working for Samsung N130. Did you happen to notice ? In my case I am not able to adjust screen brightness using hot keys! and enable/disable wireless is not working either...The only keys that work are volume up/down and mute..Would you mind having a look on it?

Thanks once again.

Sonisaus
Photo of Cedric DUCLOS

Cedric DUCLOS, Official Rep

  • 1295 Posts
  • 112 Likes
Temporary workarounds...

1. Brightness: add the Brightness applet by right-clicking on a (small) free space available in the top-right panel

2. Wireless: right-click on the NetworkManager applet and disable Wireless
Photo of sonisausS

sonisaus

  • 9 Posts
  • 0 Likes
Cedric,

Would you please elaborate on adjusting brightness? I cant figure out the small free space...
Photo of Cedric DUCLOS

Cedric DUCLOS, Official Rep

  • 1295 Posts
  • 112 Likes
Sorry for the delay!

Here is a screenshot but the area to perform the right-click is very small :)
Try in the top-left corner of the hour applet.

Photo of Enrique Morales

Enrique Morales

  • 3 Posts
  • 0 Likes
the applet not response in my Samsung N210
Photo of Zak Kaufman

Zak Kaufman, Employee

  • 4636 Posts
  • 376 Likes
The Samsung N210 cannot adjust it's brightness in Jolicloud. It's a known issue. You can adjust it while the bootloader is showing for now, though.
Photo of tarsofagundesT

tarsofagundes

  • 1 Post
  • 0 Likes
the applet not response in my dell mini 10
Photo of Iñigo Urrutia Guevara

Iñigo Urrutia Guevara

  • 1 Post
  • 0 Likes
Same me... in n210 impossible adjust brightness...
Photo of Cedric DUCLOS

Cedric DUCLOS, Official Rep

  • 1295 Posts
  • 112 Likes
Enter the BIOS and set the brightness adjustment to user control.
Then, when your computer is booting, adjust the brightness :)
Photo of sonisausS

sonisaus

  • 9 Posts
  • 0 Likes
Thanks a bunch! Any idea to make it work thru hot-keys (Fn + up arrow/down arrow)?
Photo of emuratoreE

emuratore

  • 1 Post
  • 0 Likes
I'm having the same problem trying to adjust brightness in my Samsung N120.
I spent 15 minutes trying to catch the very small free space but I couldn't (yet...)
Is there any other way to add that panel?
Photo of ouoertheoO

ouoertheo

  • 1 Post
  • 0 Likes
This is an issue for me as well. Is there some kind of driver that needs to be installed or anything?
Photo of Cedric DUCLOS

Cedric DUCLOS, Official Rep

  • 1295 Posts
  • 112 Likes
If you have a Samsung, enter the BIOS and set the brightness adjustment to user control.
Then, when your computer is booting, adjust the brightness.
Photo of thequeenscheeseT

thequeenscheese

  • 3 Posts
  • 0 Likes
Hello i know this is an old topic but ive searched for an answer with no idea and having tried these work asrounds and a couple of root terminal scripts i now have the fn brightness cursor up/down working with the slider appearing but nothing changes only the slider moves brightness stays the same?
any sussed it yet?

samsung n145plus (win7 starter also iuf makes anyodds doubt it will on other boot)

cheers????????
Photo of Cedric DUCLOS

Cedric DUCLOS, Official Rep

  • 1295 Posts
  • 112 Likes
Since you have a Samsung device, did you try what's written in my comment just above?
Photo of thequeenscheeseT

thequeenscheese

  • 3 Posts
  • 0 Likes
well i wouldnt have posted if i had and it worked, and it doesnt work in my case changing brightness in bios/boot menu with fn keys works but id like the brightness to work from within joli itself either with a setting or fn keys, also in my bios there is no brightness user control setting, the fn keys just work..
Photo of Colm Doran

Colm Doran

  • 2 Posts
  • 0 Likes
on my n145 plus after reading this i right clicked on the desktop and was able to adjust my brightness in the 'graphics properties' just now and my eyes are so relieved. i have spent ages tryin to fix the hot keys and i still cant but i dont care now that it is finally dull! thanks people
Photo of Colm Doran

Colm Doran

  • 2 Posts
  • 0 Likes
thanks again!! this is great
Photo of Sammyone

Sammyone

  • 1201 Posts
  • 78 Likes
Assuming you have a SAMSUNG N145...

try this 'sort of' brightness control...
http://techreviewonline.freeforums.or...
Photo of tomastomas444T

tomastomas444

  • 6 Posts
  • 0 Likes
i have same problem ...
i turn on this applet but it dont work
i get error: cannot get laptop ppanel brightness
Photo of Sammyone

Sammyone

  • 1201 Posts
  • 78 Likes
tomastomas444
Did you go into Setup when the computer first starts up and Enable User Control?

While the computer is booting INTO JoliOS, i.e while the splash screen is showing,
try adjusting the brightness THEN.

For an ADJUSTABLE control... Try the work around I did here...

http://techreviewonline.freeforums.or...
Photo of tomastomas444T

tomastomas444

  • 6 Posts
  • 0 Likes
i have LENOVO B570e and this tutorial not working for me
especially this : sudo setpci -s 00:02.0 F4.B=xx (for xx i write 100 or 20 or 50) ..
Photo of lanre.elL

lanre.el

  • 2 Posts
  • 0 Likes
hi. Having a bit of a problem as well with joli os. I need to watch my screen intermittently for several hours during the day while i trade securities. I changed the settings to prevent my screen from automatically dimming after a period of time. However, this didnt seem to work. Any ideas?
Photo of Zak Kaufman

Zak Kaufman, Employee

  • 4636 Posts
  • 376 Likes
What machine are you using Joli OS on?
Photo of lanre.elL

lanre.el

  • 2 Posts
  • 0 Likes
I am using Joli OS on a HP HDX9090EA.
Photo of Sammyone

Sammyone

  • 1201 Posts
  • 78 Likes
You said...
tomastomas444 3 hours ago

i have LENOVO B570e and this tutorial not working for me
especially this : sudo setpci -s 00:02.0 F4.B=xx (for xx i write 100 or 20 or 50) ..

I cannot think of any reason for this NOT to work... I even copied your 'formula' into the Terminal, dimmed the screen in stages then in the last command brought it back up and did a screenshot... as per picture below - It did NOT like 100% but accepted 99%

Photo of tomastomas444T

tomastomas444

  • 6 Posts
  • 0 Likes
Sammyone ... what can i do now ? :(((
Photo of Sammyone

Sammyone

  • 1201 Posts
  • 78 Likes
I can only HOPE, that you are using Alt+F2 to try this... it works on my
Asus 1011PX, HP Omnibook 510, Dell C400 and this Samsung N150...

Just in case - here are the actual steps...

Copy this to memory
sudo setpci -s 00:02.0 F4.B=

by hilite-ing it and tap and hold Ctrl key, then tap C key (Copy command)
Press and HOLD Alt key then Tap F1 key

A Terminal window will appear

in the EDIT menu at top of the Terminal window
click 'Paste'

Now type a two digit number between 30 and 90...
do not want it too dark to see what to do next...

Tap the enter key.... Terminal will ask for YOUR JoliOS password...
type that in... You will NOT see anything happen (so no-one can look over your shoulder and find out your password... Sad isn't it!)

Now tap the ENTER key - the Brightness SHOULD CHANGE

Repeat
in the EDIT menu at top of the Terminal window
click 'Paste'

Now type a two digit number between 30 and 90...
do not want it too dark to see what to do next...

This time the brightness should change as soon as you tap the enter key... Terminal remembers your password till you close it (or 10 minutes, whichever happens first)

Please let me know if it worked this time....
Photo of Sammyone

Sammyone

  • 1201 Posts
  • 78 Likes
I just found THIS...

http://ubuntuforums.org/showthread.ph...

How to install Ubuntu 11.10 x64 on Lenovo (U)EFI + GPT fix WLAN + Power / Update BIOS

in section 3 Tweaks & Fixes....
3.1 Fix Brightness keys...

Yes it is 11.10, but try the 'Fix' it MIGHT work for you,...
Photo of Sammyone

Sammyone

  • 1201 Posts
  • 78 Likes
Needless to say, it does NOT work on my Samsung...

Is it Samsung or JoliOS that is failing?
Photo of tomastomas444T

tomastomas444

  • 6 Posts
  • 0 Likes
vrrr... JoliOS block it .... NOT working form me ...
i only get message : "No outputs have backlight property"
Photo of tomastomas444T

tomastomas444

  • 6 Posts
  • 0 Likes
i try this ... http://nikunjlahoti.com/2012/04/29/ub... but not working too
Photo of Sammyone

Sammyone

  • 1201 Posts
  • 78 Likes
Did you use this code - EXACTLY ?
$ sudo vi /etc/default/grub

My guess is that you did...

IGNORE the $... You already have that... see this line from My terminal...
sammysix@jolicloud:~$

in fact I suggest you use THIS code...

sudo gedit /etc/default/grub

Gedit is a bit easier to use... (IMO)

There is about 30 lines of code in the file but I'm only showing the ONE line that we are talking about...

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor intel_idle.max_cstate=0"

It shows up as 2 lines here.. 'cos the page isn't wide enough...

Please try again...
Photo of tomastomas444T

tomastomas444

  • 6 Posts
  • 0 Likes
friend ... YES i dont use $ ... i use without it ! IM NOT IDIOT !!!!
i try it with this: intel_idle.max_cstate=0 but no change ,.... :((
Photo of Sammyone

Sammyone

  • 1201 Posts
  • 78 Likes
If none of the above work... then there is nothing else I can do... Sorry.

At least your Wireless appears to be working - which is the MAJOR complaint on the forums...

I was not calling you an idiot... I have to spell out possible problems, as MOST people who visit this site cannot even find out how to open a Terminal...

Your computers architecture seems to be WAY different from the norm, if these simple codes are not working on your Notebook

After even more research on your behalf, - I find that - even Canonical the distributors of Ubuntu do not list your Notebook as Ubuntu certified...

Quote "Canonical works closely with Lenovo to certify Ubuntu on a range of their hardware.- "

http://www.ubuntu.com/certification/d...
Photo of Jeremy Andrews

Jeremy Andrews

  • 1 Post
  • 0 Likes
Hello. I'm having a similar problem with my Samsung N150-P. I can adjust the brightness with the BIOS, and if I adjust the brightness in Joli OS settings it will change the next time I turn the computer on, but this is really inconvenient if I want to change the brightness repeatedly while the computer is on.

I tried installing the Linux On My Samsung drivers which have always gotten my computer to work with Ubuntu, and I assumed it would work with Joli OS as well since it's based on Ubuntu, but it didn't.
Photo of Sammyone

Sammyone

  • 1201 Posts
  • 78 Likes
I no longer have an NC10 (BrianNC10) on which Vorias tools worked. I have since had a Samsung N150-P for over a year and STILL cannot get Voria's tools to work on it, since a Kernel update..

There is a work around I managed to fudge - so I CAN adjust brightness manually (well by a quick trip to Terminal) using the method I suggested above, by modifying .bashrc

Open a Terminal and type in the following code...

sudo gedit /home/your_username/.bashrc ie MY your_username is sammyone

If a blank file opens - you got something wrong...

If the right one opens, go down to where there are SOME aliases listed

add the following aliases... between the last one and ‘fi’

alias bri='sudo setpci -s 00:02.0 F4.B=70'
alias mid='sudo setpci -s 00:02.0 F4.B=45'
alias dim='sudo setpci -s 00:02.0 F4.B=20'

save and quit then Log-off or reboot...

After re-starting,

If the screen is too bright - open a Terminal and type
mid
Your brightness should go down even more

Typing dim should dim the display

Typing bri should be quite bright...

YOUR brightness levels may need to be different to mine - 65, 40 and 15...

Hope this was helpful