Corrected loved tracks cannot be unloved

  • 11
  • Problem
  • Updated 6 months ago
  • Acknowledged
  • (Edited)
I wanted to clear all my loved songs and I almost did it. Only one song left and I dont know it's a bug or some kind of easter egg because it's Van Halen - Can't stop loving you. It has empty heart (not red) and even this song is on my loved list. Dont sure what to do about this.

@EDIT My lastfm username is Garfieldek, also I dont have turned on auto correction
Photo of Łukasz Ziaja

Łukasz Ziaja

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 11
Photo of Jon

Jon, Community & Customer Services

  • 4985 Posts
  • 3666 Reply Likes
Official Response
The problem here, as Laura suggested, is that your loved track library is displaying a track (or artist) that has been auto-corrected from a different spelling.  It doesn't work because when you try to un-love the track, you're unloving the corrected track, not the original spelling.

A bug ticket has been opened to address this problem, but in the meantime a possible workaround to try is to un-love the original, un-corrected track from it's /+noredirect/ catalogue page.  

For example, if you scrobbled "Annie Lennox - I Put a Spell On You" from Spotify and marked it as a loved track, the page you need to navigate to is: https://www.last.fm/music/+noredirect/Annie+Lennox/_/I+Put+a+Spell+On+You+%28Fifty+Shades+of+Grey%29...

The difficulty is finding the right page, as even with auto-corrections off in your settings, your loved tracks page will still show the corrected spelling.  You may need to go through your mp3 collection and check to see if the track name or artist is spelt differently to how it appears in your library.  Likewise, if you're scrobbling from Spotify, look up the track and check to see if it has a different spelling to how it appears in your library.  

Once you think you've found it, turn off auto-corrections, then scrobble the track to your profile -- the uncorrected link should now display under "Recent Tracks".  Click on the track name to navigate to its catalogue page (it should have /+noredirect/ in the url, and display a blue "Did you mean...?" message near the top), check that it's marked as a loved track, and click the red heart icon to unlove the track.  Then check your loved tracks to confirm that it's gone  -- if not, you either had the wrong spelling, or it's a different issue (See: 1. Can't un-love track because the artist name has a space at the end, 2. Can't unlove track because there's no catalogue page / URL).
(Edited)