Missing tags on artists profile page

  • 8
  • Problem
  • Updated 3 years ago
  • In Progress
Listening to the act SEXWITCH http://www.last.fm/music/Sexwitch for the first time and I notice that there aren't any tags connected to this artist. The last weeks I've come a cross a few artists that have either NO tags or only one or two but who do have thousands of listeners and 100 thousands of scrobbles. Have people stopped tagging or is there an issue?
Photo of E-Clect-Eddy

E-Clect-Eddy

  • 299 Posts
  • 89 Reply Likes
  • puzzled

Posted 4 years ago

  • 8
Photo of E-Clect-Eddy

E-Clect-Eddy

  • 299 Posts
  • 89 Reply Likes
This problem is taking way to long to solve, it's open for at least 4 months and no answer on when it is gonna be fixed. It's unworkable at times and it's just no guessing which tag is gonna stick and which had stuck but is not visible

common guys this needs to be dealt with, meaning get a fix. or at least some kind of workaround.
Photo of Jon

Jon, Community & Customer Services

  • 5014 Posts
  • 3686 Reply Likes
Official Response
Thanks for bearing with us, this is still being worked on I'm afraid.

To clarify what you're seeing, there are two issues here, both of them are display issues - no data is being lost, it's just not being retrieved / displayed  on website correctly.

The initial question you posted (regarding the global tags of SEXWITCH) has been answered, and there's no change:  global tags aren't being processed in the back end yet, and so while posting tags is working (sending data to last.fm), the data is not currently being counted towards an artist's overall tags.  For major artists you're not going to notice this, but obviously it's more apparent with newer artists.  I've been told that the data team are close to fixing this, so you should see new artists populated with global tags soon.  An important thing to stress here is that the data isn't being discarded -- your tags will be counted once the global tag service is back up and running.  

----
[update: 16th May - the following issue should now fixed:]

As for the issue of personal tags disappearing, this is a synchronisation issue which is currently being worked on.  When you refresh a catalogue page or add a new tag, it's currently swapping between two different sets of data, which should be in sync (i.e. both display the same tags).  

E.g. I just tagged Test Artist with test1, test2, test3, test4, test5, test6, test7, test8

When I refresh the page I see either:

Set one: test6, test7, test2
Set two: test8, test3, test5, test4, test1

Same things happens if I call the api:

http://ws.audioscrobbler.com/2.0/?method=artist.getTags&artist=Test%20Artist&user=Maddieman&...




We thought this issue had been fixed last week, but it still persists so we're taking another look.  In the meantime, I wouldn't worry about tags 'sticking', so to speak.  If you submit the data, and it says "successful" then we do have the tag, it's just not being retrieved and displayed on the site correctly (including the tag entry box).
(Edited)
Photo of Jon

Jon, Community & Customer Services

  • 5014 Posts
  • 3686 Reply Likes
Official Response
The bug with adding personal tags has now fixed -- the problem was a synchronisation issue between to replicas, personal tags were being written to one or the other, and not both.  No data was lost, and if you check your examples they should display correctly now.