Extension doesn't work in Google Reader

  • 1
  • Problem
  • Updated 9 years ago
  • In Progress
FF extension doesn't seem to work wih Google Reader. Whenever I click an icon - it says it can't identify which item is currently selected. And clicking on a story doesn't help.
Right-click on the link and selecting "Send to LL" works, but with alert pop-up.
Photo of Ilya


  • 16 Posts
  • 1 Reply Like
  • disappointed

Posted 9 years ago

  • 1
Photo of grex

grex, Official Rep

  • 103 Posts
  • 20 Reply Likes
I'm sorry about that -- unfortunately, I couldn't reproduce the problem on multiple machines until now.

Could you give me a few more details on: 1) which browser you're using and 2) which feed you're having trouble with (or feed view, such as a tag/folder). In order for the detection to work, the Google Reader item has to have a blue border border around it (that shows that it's the current selection, but I'm sure that's the case)
Photo of Ilya


  • 16 Posts
  • 1 Reply Like
Sure, thank you for replying.

Here's my browser info:

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/2008070208 Firefox/3.0.1 ImageShackToolbar/4.5.0

*** Extensions (enabled: 52, disabled: 9; total: 61)
Adblock Plus
Adblock Plus: Element Hiding Helper 1.0.5
Add N Edit Cookies

Autofill Forms

Better Flickr 0.3
Better GCal 0.3
Better Gmail 2 0.6.1
Better GReader 0.3
Better YouTube 0.4.3
BugMeNot 2.0
ChatZilla 0.9.83
Configuration Mania 1.09.2008081401 [disabled]
Cooliris Previews 2.6.4

Ctrl-Tab 0.19.1
Custom Download Manager 1.6b
CustomizeGoogle 0.75
del.icio.us Complete 1.3
Download Statusbar

DownloadHelper 3.2 [disabled]

DownThemAll! 1.0.3
Easy Job Application 1.4.0
Extended Statusbar 1.2.8
Extension Manager Extended 2.7
Fast Dial 1.90
Firebug 1.2.0b15 [disabled]
Firecookie 0.6 [disabled]
FireFTP 1.0.2
Fission 1.0

Flashblock 1.5.6
FoxClocks 2.4.91
Foxmarks Bookmark Synchronizer
FxIF 0.2.3
Gmail Manager 0.5.5
GMarks 0.9.9 [disabled]
Greasemonkey 0.8.20080609.0

ImageShack® Toolbar

InfoLister 0.10
LaterLoop 0.3.1
Linkification 1.3.5
LiveJournal Addons 8.3.1
Locationbar2 1.0.3
Menu Editor 1.2.6
Organize Status Bar 0.6.2
Paste and Go 2 0.8

Peers 0.7.4 [disabled]
Read Easily 1.0.3
Read it Later 0.9821 [disabled]
RetailMeNot 2.2
Save Complete 0.9b11
ScribeFire 2.3.2
Searchbar Autosizer 1.3.10
Secure Login

Smart Middle Click
Source Viewer Tab 0.2.2008061901
Stealther 1.0.6
StumbleUpon 3.26
Stylish 0.5.7 [disabled]
Tab Mix Plus 0.3.7pre.080728
URL Link 2.02.2

User Agent Switcher 0.6.11 [disabled]

*** Themes (4)
Default [selected]
MacOSX Theme

*** Plugins
Adobe Acrobat
iTunes Application Detector
Java(TM) Platform SE 6 U7
Microsoft® DRM
Mozilla Default Plug-in

QuickTime Plug-in 7.5 (861)
Shockwave Flash
Silverlight Plug-In
Windows Media Player Plug-in Dynamic Link Library

There's no particular feed that LL doesn't work with. I always use "All Items" view.
GReader indeed shows blue border on active feed.
I tried disabling Better GReader addon but it didn't helped.

I could try something else if you have any ideas what to try.

Thank you.
Photo of grex

grex, Official Rep

  • 103 Posts
  • 20 Reply Likes
Thanks so much for taking the time to put together this list. I haven't been able to spot an obvious culprit or cause for the problem -- I suspect that another extension is modifying the HTML/DOM of the Google Reader page such that LaterLoop doesn't recgonize it anymore.

Specifically, LL looks for an element with the ID "current-entry", which should contain an [h2] heading and at least 1 link with the CSS class name "entry-original" -- maybe that can help us figure out the problem.

Maybe it's another Greasemonkey script? Have you tried disabling Greasemonkey temporarily?
Photo of Ilya


  • 16 Posts
  • 1 Reply Like
OK, so I disabled Greasemonkey (addon), Stylish, all my Better whatever addons - and it still won't work! I don't get it :)
And this is what goes into error console on Ctrl+Space:

Error: [Exception... "'JavaScript component does not have a method named: "handleEvent"' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)" location: "" data: no]

I don't know if this helps, just in case.
Photo of Ilya


  • 16 Posts
  • 1 Reply Like
This is from Firebug. All items, first entry.

Photo of Ilya


  • 16 Posts
  • 1 Reply Like
Sooooooooooo, there's no news about this bug? :(