problems to publish panoramas to web

  • 1
  • Question
  • Updated 8 years ago
i had created a panorama but wen I click publish to web nothing hapens
Photo of Luis

Luis

  • 2 Posts
  • 1 Reply Like

Posted 9 years ago

  • 1
Photo of Nathanael Lawrence

Nathanael Lawrence

  • 795 Posts
  • 55 Reply Likes
Can I assume that you are creating the panorama with ICE?

If that is the case, you will need to have the Photosynth app for Windows installed and you will also need to have gone to Photosynth.net, signed in with your Windows Live ID and chosen a Photosynth username for that account so that the panorama will have somewhere to upload to.

---

Please keep in mind that ICE will only upload panoramas to Photosynth.net which have been stitched with the 'Rotating Camera' camera motion in ICE.

---

If you have both ICE and Photosynth installed on the same Windows machine already, but ICE is not passing the panorama to the Photosynth app for upload when you click 'Publish to Web', it is probably because your Windows desktop has an accented character in your Windows username. What that means is that in the file path to your Windows account's 'Temp' folder (which ICE uses to store the panorama files in) also has an accented character in it and when ICE attempts to pass that accented character to the Photoynth app, it will fail - meaning that the Photosynth app never receives the location of the panorama on your hard drive in order to upload.

You can fix this by choosing to assign your 'Temp' folder to a different address (customize Windows' 'Environment Variables') or by using ICE's menu to change the location of ICE's working folder to an address which does not contain accented characters.
Photo of Luis

Luis

  • 2 Posts
  • 1 Reply Like
Thank you very much for your assistance. I am very happy with this reply and it work ok at moment. Best regards and thanks again.
Photo of Dan Doherty

Dan Doherty

  • 3 Posts
  • 0 Reply Likes
You refer to accented characters - not sure what this means. Still cannot upload panoramas using ICEl Need more help if you can give it.
Photo of Nathanael Lawrence

Nathanael Lawrence

  • 795 Posts
  • 55 Reply Likes
Hi, Dan.

By accented characters, I just mean any non-ASCII letters.
A few examples: à, á, ã, ä, è, é, ê, ë, ì, í, î, ï, ñ, ò, ó, ô, õ, ö, ù, ú, û, ü, ý, ÿ
Photo of Dan Doherty

Dan Doherty

  • 3 Posts
  • 0 Reply Likes
Nat

I have tried everything in the book to upload a panorama - changed the temp area to another - even installed the thing for photoshop - will only let me upload a Synth - keeps telling me synth software not installed - ICE won't let me publish to the web - gotta be a better way - perhaps it's because I'm using Windows 7 .. I'm ready to throw in the towel.
Photo of Nathanael Lawrence

Nathanael Lawrence

  • 795 Posts
  • 55 Reply Likes
Nope, I've used Photosynth on Windows 7 perfectly since the public beta of Windows 7 was available in 2009, so it's not the problem.

I've run Photosynth and ICE on many different computers without problems with Windows xp, Windows Vista, Windows 7, and 'Windows 8' Developer Preview.

It sounds like some setting is wrong with your particular machine.

Could you please post the full address of your temp directory?
Example: C:\Temp\ICE\

Could you record a screencast of the process and upload it to vimeo? It would help to be able to see actual error messages.

If I can't help you (I'm just your fellow user), please contact the ICE team on their forums.
Photo of Dan Doherty

Dan Doherty

  • 3 Posts
  • 0 Reply Likes
Folks

Let me go through my problem again – and I will try to be more specific on what I’m doing and what the system does when I try to upload a Panorama photo – not a Synth if you know what I mean.

Next I open ICE and load a number of photos which automatically stitches them (using Rotating Motion) setting. Now I am looking at a panorama created with ICE. There are no other things I can do now except publish to my account.

I have also changed the temporary file location in ICE to be C:\Temp\ICE.

When I select “Publish” – I’m told that Photosynth is not installed. So, I go to the program files and click on Photosynth which (I assume installs it).

Then, I go back to ICE – select Publish to Web – then the same message appears “Photosynth Not Installed” – “Do you want to install it now” Yes or No. I then select Yes – that takes me to the upload page – waiting for me to upload – Sp I select Upload – which does nothing except refresh the same web page.

So – the little green Photosynth flower is at the bottom of my computer screen – I click on it and it opens a new blank ICE page.

Obviously I cannot open ICE to create a Panorama – I must first install Photosynth. Once done, I must use ICE which automatically opens asking me to start the whole process over. Once the photos are loaded into ICE, it iploads to the web – skipping any indication of a Panorama. Checking the C:\Temp\ICE directory, shows that is in use.

For the life of me, I cannot get ICE or Photoshop (with the plugin) or anything else to upload a Panorama – or am I missing some area in the ICE software that will permit a single-stitched photo to upload? I’m not the smartest kid on the block and would sure like to meet the one who figures this out for me!
Photo of Nathanael Lawrence

Nathanael Lawrence

  • 795 Posts
  • 55 Reply Likes
For @Dan Doherty:

Eric Stollnitz from the ICE team, recently posted something on the ICE forum (it is currently at the bottom of that page) which solved the problem you're having for Photosynth user @daphra.

Please give it a try and write back to Eric if his solution doesn't work for you.

Wishing you success!
Your fellow panner and photosynther,
.nl