Can't register for Luna Account/ID

  • Problem
  • Updated 4 years ago
Trying to create a Luna ID account and encountered several problems. First time I completed the registration form I got an error message; clicked on the support link...which was in Japanese! (so I went to the URL & changed "jp" to "en"). Finally navigated back to registration form & realized that my chosen Luna ID was taken. Changed it, repeated above process only to get another error: my email address was already registered, presumably from my first supposedly unsuccessful attempt. Changed it, and got yet another error. Tried to log in anyway with both usernames I tried to register. Finally gave up and here I am. If using iLunascape browser is as much trouble as this process has been, I'll delete it from my iPod and try another browser. I don't have time for all this hassle! Thanks for any assistance you can provide.
Update: After clicking the "post" button it gave several log-in options; I choose Google and nothing happened. It said pop-up blockers might need to be disabled but I haven't figured out how to do that here yet. Gave up on Google log-in attempt and just signed up for a Get Satisfaction account. At least THAT registration seems to have worked...except I feel anything but satisfied!
Photo of mousepotatoM

mousepotato

  • 1 Post
  • 0 Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Sarah

Sarah

  • 177 Posts
  • 5 Likes
Hi Lisa,

The Luna ID is required when you want to upload skins or plug-ins you've developed with other users. Is this what you're trying to do? If so, please let me know your registered ID (UserName), so that I can have the team to look up and activate the account. Also, this is for Lunascape desktop browser, so it is nothing to do with iLunascape at this moment.

Regards,