Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m undecided

[Code49] Enconder mackie control mode

hi!

my name is Victor.

i need help and information to solve this little problem.
the problem arises when I updated firmware 1.0.2.7 (last versión).
The keyboard work perfectly except the ''encoders in mackie control mode''.



In the control editor can be solved?
I personally have not found the option in the control editor for this little problem.

bye!
1 person has
this question
+1
Reply
  • Hi, Viktor. I might be able to help, but can you explain to me what's going on with your encoders? It wasn't clear to me from the video.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly

  • I’m undecided
    hi stf!

    As I explain it to you so that you understand it well.
    The problem is that the mark a minimum value or a maximum value without being gradual in mackie control hui mode.

    example:

    [midi mode] rotate to right E1,E2,E3,E4,E5,E6,E7,E8 (0,1,2,3...127) and rotate left E1,E2,E3,E4,E5,E6,E7,E8 (127...3,2,1,0) works perfectly and values is a progressives.

    [mackie mode] rotate to right E1,E2,E3,E4,E5,E6,E7,E8 (1,5,2,8,6,3...) and rotate to left E1,E2,E3,E4,E5,E6,E7,E8 (70,66,72,68...) no works fine and correctly values.

    That only happens in mackie HUI mode, in midi mode it works correctly.

    I suspect that it has to be by some parameter of the configuration CC but I have not been able to find out what parameter it is.

    PD: Forgive me if I explain myself very badly because I do not speak English correctly, it's because I'm not native.

    bye stf and thanks for help me!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly

  • Hi Viktor,

    Thanks for posting!

    This actually looks normal. In Mackie Mode, the knobs will work in a sort of relative format (+1/-1) as opposed to absolute (0-127).

    So instead of sending an absolute position for the controlled parameter to assume, a relative value will tell the controlled parameter to simply go up or down from it's current position. This helps more if you may be controlling a parameter from more than one location, i.e. from the Code and from simply clicking in the DAW. This way the control doesn't jump when it receives an absolute position that's different from it's current position.

    Unless it's acting strange when assigned to a Mackie Control script in your DAW, everything looks fine!

    Let me know if you have more questions!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly

  • I’m indifferent
    hi corey S!

    thaks for read my post!

    You are very right in what you say.
    I just tried the fl studio 12.4.1 and it works perfectly even though the lcd of the keyboard indicates value 1/65. The inconvenience is that I am using maschine 2.0 and that is where the issue fails. Because it is a minimum or maximum value (+ 1 / -1) maschine 2.0 is using it in absolute values between 1/65.
    I like it better when the mackie control encoders used absolute values 0/127.

    How can i fix this? you mentioned something about a script, Illustrate me.

    Thanks for the help!

    bye!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly