I’m frustrated

AirDrums don't load Loops from Expansion Packs

Hello
I just bought Trigger Finger Pro downloaded the latest software and everything works fine except AirDrums doesn't seem to load any loops from the expansion packs. It does load most of the presets but no loops from any pack. Any ideas??
3 people have
this problem
+1
Reply
  • Hello,

    Thanks for posting. Happy to help!

    I'm unable to get that to happen over here; odd. Had you installed or moved these to an external or cloud drive? If so, try installing one of the expansions to the internal drive and re-test.

    It may also be a deeper Windows registry problem, in that those files are not being properly opened/accessed. Try cleaning your registry with this free program:

    CCleaner

    There is a Registry Cleaner option where you can "Scan for Issues" and "Fix Issues". It is probably better to fully reinstall the Expansion in question first on an internal drive then run the fix.

    Hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • I’m frustrated
    I tried everything you said, I've uninstalled, downloaded and installed again everything to "C:", did the clean up, even tried the Repair option of the expansion packs but I still can't load any loops. I see that the size of the expansion packs is 2,57GB far less than the 8GB promised. This could be due to compression but I'd like to mention that
    Thanks for helping anyway!!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Yeah same problem here I even paid the 99$ for the extra ones and can not get those to work I told all my friends that this was going to be the best hardware to buy for my studio and it has become a nightmare I'm starting to think not even the guys at m-audio know how this shit works where are the updates and where is the customer support I wanna give this trigger finger the finger
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Hi, everyone.
    For Me - already helped Dan R (employee)... Running Arsenal as Administrator fixed this problem. If You use Arsenal as Vsti - then run as administrator Your DAW.
    Every loop (synths, drums etc...) will be working.
    One more time - Thank You Dan R!
    I love TFP. I gave her all my nights and days....
    Nothing can stop me from making evil good electronic beats____
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • I’m confident
    Uninstalled, downloading and reinstalling everything again.
    x64 Standalone version of Arsenal now loads loops!! (yeeahh!!)
    but x32 vst version in Live 9.1 (x32) doesn't.
    Could be a deeper Windows problem or other corrupted file,
    I'll find out in the future when I'll format my pc
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • 1
    I have exactly the same problem and none of the above helped. This is a pretty fresh install of windows 7, 64 bit (a week old) with only my audio kit installed, so I'm rather surprised. Also, on occasion, I get an odd error launching arsenal standalone. "Another Vip application seems to already be running. This instance will now exit."

    If you look at the screenshot, you will see an example of the "tocadisco pad lp 15 am 124" loaded, and each pad assigned, but no samples show. There are no samples in sample A, or B.

    This is true for every single "loop" item I have tried from the bundled software, and what's more, I cannot load a sample to pitched bank. That doesn't work either.

    I was convinced that I was doing something wrong, but I've read through the manual several times (the big 60 page one), watched all the official tutorial videos several times, and I cannot find a thing I'm doing wrong.

    Seems someone else has this problem too, so it's not just me.

    I have reinstalled, run as administrator, turned off UAC, tried 64 bit, 32 bit, compatibility modes, etc.

    64 bit versions of Airdrums load loops properly, but 32 bit simply does not. This is a problem, because I have to use ableton 32 to load many of my VST fx, and 32 bit ableton will not load a 64bit VST.

    As it turns out, I'm a systems Admin, and have access to many, many windows boxes. I have tried the same installers on 3 laptops, 2 desktops and on windows 8 and 7, and all have EXACTLY the same problem.

    There is something broken clearly in the 32 bit version.

    It would be nice if this could be fixed please. M-audio?

    • Yes, I have pretty much the same.Downloaded, unzipped,installed all software and applications from the TFP site. Exactly for my Win 10 (X64) OS. And, Hybrid 3 works, but Arsenal can not open AirDrums at all. No sounds. I have the same screenshot: At AirDrums editor, no sample (WaveForm) at all. CanÅ¥ believe it is paid, professional (Even branded as "PRO") software. It ruins the chances of the very promissing TFP hardware,...
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • hey all.
    just bought my tfp and i'm having the same problem. No loops are working. they all load fine but getting no sound! Can't anyone at M-audio help us out?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • i also found that airdrums has a problem changing banks! When pressing bank b it just flashes and stays on A. But if i then click on bank C it changes to bank B!! wtf is wrong with this software! The machine itself is awesome but the software really needs some attention! NOT what i paid for M-audio!!!
    • Yeah, I love my Trigger Finger Pro, but hate Arsenal itself. The only thing I've found it useful for is when I'm at work, and I tap out some good drum sequences, the Arsenal software will allow me to export that from the device and then allow me to import it to my TFPro at home. That's seriously the only benefit to this. Good luck with it recognizing your other VST instruments. Even if it does, you get some seriously erratic results.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • 2
    so my problem has been solved! I uninstalled and reinstalled everything and now it all works! Don't know why but it works..run as admin! Hope you all get it sorted as well.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • I ran into this same issue a few hours ago. In my case it was because my OS is 64bit but I am running Ableton/Arsenal in 32. Had no issues until now because I am installing all my plugins in 32... Until Air Drums that is...

    In order to make the loops work it seems you need to run the Arsenal 64 version in a 64 OS. If you run the 32 version in a 64 OS... you get the loop issue mentioned above.

    The workaround: install jBridge. There are a lot of tutorials on the internet explaining how it works. It works both converting your 32 bit pluging into 64. It also works the other way around. I can bet this will solve your issue. And please, forget about CC Cleaner, registry and whatever... it has nothing to do with it. I hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited