Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m sad

Axiom 25 and Mac OS 10.15 Catalina

Is there any way to connect my Axiom 25 to Mac Book on Mac OS 10.15? Drivers for my Mac are outdated and apps for installation are no more supported. How can I do it?
1 person has
this question
+1
Reply
  • Hey Daniil Chubanov,

    Thanks for posting!

    The Axiom is a legacy product and has not been tested for compatibility with macOS Catalina. That said, the unit is class complaint and should be able to operate off of your computer's core MIDI drivers.

    The issue would be more on the software side. Catalina dropped support for 32-bit software so many programs were rendered incompatible. To use the Axiom with your computer, you would need to install a DAW that is fully supported on Catalina. Sweetwater compiled a compatibility list that you can reference from the following link:

    macOS 10.15 Catalina Compatibility List

    Let me know if you have any questions!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated