I’m confused

Axiom AIR 49 - Problem setting up with Logic Pro X HELP!

Good day! I have a problem with my new Axiom Air 49. I use a MacBook Pro 10.9.5 and Logic Pro X version 10.2.0. I have always had compatibility problems with all my previous MIDI controllers before (axiom 25 2nd gen, axiom 61) but it was just matter of downloading and installing the required drivers and why not (DirectLink in this case) but now with this new axiom Air 49 nothing I've tried works.
I have read and done pretty much everything suggested in previous posts with no results. I have followed the steps of downloading, copying and pasting the axiom air bundle. I have downloaded and installed the drivers for the keyboard. I have set up the controller in my logic pro x preferences... still no results. Funny thing is, when I first unboxed it and plugged it in it worked right a way. Now when I turn on my midi keyboard a "pan 1" message appears on the LCD display.
Lastly, I would like to know if installing the AVID Pro tool Express package that comes with the keyboard could create any type of conflict with logic since the keyboard was working before installing this software in my computer.

Thank you in advance for your help!!!
1 person has
this problem
+1
This topic is no longer open for comments or replies.
  • HI Andy,

    Thanks for posting!

    I'm still not entirely sure what is happening if anything. Can you describe where you are running into trouble?

    Pro Tools should not interfere with Logic in any way, though if the problem only started after installing Express than I recommend uninstalling Pro Tools Express. Pro Tools does have different MIDI drivers it will install which could interfere with Logic's MIDI input.

    That being said, we can't rule out Logic as a problem either. You should go through some of their troubleshooting steps. Usually deleting the preference file will clear up a lot of strange issues:

    https://support.apple.com/en-us/HT200260

    Lastly, never hurts to re-configure the MIDI Studio, especially after installing Pro Tools or if you are constantly plugging and unplugging USB MIDI devices:

    http://community.m-audio.com/m-audio/...

    Let me know how this goes!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Thank you for your replay Corey. I upgraded my OSX to the most recent "El Capitan" now and re installed the logic pro x again. Thank you for the links I have followed instructions and everything seems ok, both computer and logic recognize my MIDI controller. The problem I'm having is with Hypercontrol... I have downloaded and copied the AxiomAir_bundle since I wanna be able to take advantage of this feature and use all the controllers not only the keys. but I found (again after reseting/upgrading my computer) that after copying and pasting the axiomAir bundle to the MIDI device Plug ins folder and after setting the control surface preferences as per your instructions in prev post, my midi controller freezes immediately and a "SE.NOT.ImpI 26" error shows up in the LCD display.

    Cheers!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Thanks for the update!

    That error message just means you'll need to update the firmware and while you're at it I want to make sure that you have the latest driver as well.

    Here are the links:

    Axiom AIR - Mac Driver

    Axiom AIR - 1.2 Firmware Update (Mac)

    Now, neither of these are technically supported for use on OSX 10.11, but there's a good chance they will work just fine. The board itself is class-compliant but the drivers are required for more advanced functions like connecting to the Hypercontrol.

    Try it out and see if it works. I'd recommend diswconnecting any other USB-MIDI devices when running the update and definitely have the keyboard plugged directly into the computer. No USB hubs.

    If this fails, you could also try updating the firmware on a computer running 10.10 and that should work correctly.

    Let me know how it goes!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • I’m happy
    1
    Excellent!!! thank you very!, problem has been solved. I downloaded and installed the driver and the firmware and made sure the axiom bundle was in the midi folder in logic and the midi controller is working flawless now.

    thanks again for your support!!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited