Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Code 25 HID button mapping to "undo" (Cmd+Z) in ableton live

With the Code25 buttons in HID mode I set a button to CMD+Z command to trigger "Undo" in Ableton Live but it's not working.

I got other mappings working. For example CMD+S for saving, although I had to set it to Option (Mac) in the Preset Editor in order for it to work.

I tried using Option (Mac) + Z as well but no luck here. How can I get the Undo working?
1 person has
this question
+1
Reply
  • Hey wobbleboxx,

    Thanks for posting!

    Since the Code's buttons are sending HID protocol in HID mode, they will work much in the same way as your computer's keyboard. With that in mind, we can test with another application that uses the Undo keystroke. Since it sounds like you're using a Mac, let's try testing with something simple like TextEdit. Enter some text into a TextEdit document and press the button you assigned to the Cmd+Z keystroke. If all went well, the text should be removed.

    If that's not working, let's try manually assigning the keystroke directly on the Code instead:

    1. First, press the Button Mode button so that the display reads HID.

    2. Press the Edit button on the Code.

    3. Press the button on the Code that you want to assign to Undo - its name will appear in the display (B1, B2, etc.).

    4. Press the Data 1 Key on the Code.

    5. Use the up and down arrow buttons on the Code (under the display) to select Z.

    6. Press the Data 2 Key on the Code.

    7. Use the up and down arrow buttons on the Code to select M CMD.

    8. Press the Enter key on the Code.


    If that does work for you, be sure to store the preset on the Code hardware by pressing the Edit button, pressing the Store key, choosing a preset slot with the arrow buttons and pressing the Enter key to save it.

    I hope that helps you! Let me know if you're still having trouble!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited

  • Hi,

    thanks for the tip with TextEdit. The problem is that when I set it to key "Z", it will output "Y" (I'm using german keyboard layout, duh!). I changed it to "Option (Mac)+Y" and now the intended "CMD+Z" works fine.

    That editor is a bit of a mess when it comes to key mapping. At least for me it was.

    Don't know why "CMD" and "Option" is switched though. This should be the same on american keyboard layouts?

    Anyways, it works now! :)
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited