Help get this topic noticed by sharing it on Twitter, Facebook, or email.

CODE 49 FL Studio Trouble

Im trying to configure my Code 49 to FL Studio but my knobs, faders, encoders and x/y pad isnt working, how do I get those enabled? I already made everything MACKIE mode and FL Studio still wont auto map my keys.
1 person has
this question
+1
Reply
  • 1
    Mackie mode is mapped to mixer only (faders to volume, knobs to pan, buttons to mute/solo etc). If you want it to be mapped to plugins you should do it manually by switching Code to MIDI mode and using "Override generic link" feature in FL Studio. There is a video on official Image-Line YouTube channel how does it work.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Corey S (Official Rep) May 06, 2016 19:03
    Hi,

    Thanks for posting!

    Just follow this setup guide and it will walk you through the entire procedure:

    Code Series - Setup in FL Studio

    Please Note: When you're looking at the MIDI Preferences window, below and to the right of both the Output and Input windows, you'll see a "Port" setting. With MIDIOut3 (Code) and MIDIIn 3 (Code), set both of these port fields to "102."

    Please make sure that you are only assigning MIDIIn3 (Code) to Mackie Control Universal. If you set the first Code port to anything other than "Generic Controller" your keys and pads may not work correctly.

    I hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned