Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

Code49 not working with FL Studio 12 and unable to access support though registered

Hello,

I bought a Code49 yesterday and in spite of reading the code series entry about using the code49 with FLStudio, and following the instructions, it refuses to work. I went to my account on M-Audio where I registered my product, and I can't contact support without a coupon. I am supposed to have a coupon after registration, but that's nowhere to be seen and the contact form is asking for registration details such as the code49 serial although I am signed in. What's going on? How can I get support and above all, how can I get this to work with FL Studio 12?

Thank you
1 person has
this question
+1
Reply
  • Corey S (Official Rep) March 18, 2016 14:38
    Hi Chris,

    Thanks for posting!

    At what point in the guide did you run into trouble? What's not working?

    Check out the picture and try to match it:



    - Click on "Code 25" in the Output section and check off "send master sync"
    - Click on Code 25 in the input section and select the "Enable" button
    - Click on MIDIIN3 (Code 25) in the input section and select "Enable." While this is selected make sure to also set the "Controller Type" to "Mackie Control Universal." This may happen automatically.

    The Code will use the Mackie protocol to map out to most DAWs, including FL Studio. This is like a universal controller language that will match faders and knobs to faders and knobs in your software. So it's just a matter of activating the right ports and setting up the controller correctly.\

    On the code, you'll also need to:

    - Press EDIT
    - Hold SHIFT and press the key labeled "MACKIE/HUI"
    - When the display reads "MACKIE" just let go

    You'll also want to press the fader/button and encoder "MODE" buttons until they're green so that they will send as Mackie instead of MIDI or HID.

    Finally, if you're missing a support code, contact our support team using the following methods and they'll still be able to help you out:

    • Submit Registration inquiry with our Technical Support team by logging onto the M-Audio Support Page. Select Product Registration Inquiry from the drop down menu. This will not require a support code.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Hi Corey,

    I followed these procedure as per the code series I found online. Apart from the fact that mine is a 49, not a 25, I did what is displayed on your picture. I also set the Mackie option on the keyboard and turned the mode buttons to green. Since that was correct, my only guess is that I am not setting the ports properly. I did try changing ports without sucess (in the FL Studio config). Can you tell me what port config I should be using in FL Studio? And perhaps what is overlooked here is what setting I should be using on the keyboard to send midi data to the right ports: maybe it is as simple as that and there is a step missing in the instructions to get the keyboard to send data: currently, there is no data coming through to FL Studio.

    Thank you for your assistance.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Corey S (Official Rep) March 25, 2016 19:28
    HI Chris,

    Can you send me a screenshot of your preferences looking exactly like the picture I posted above? That will help me confirm that you're not missing anything.

    I'm also going to assume that you are using Windows here and I want you to try uninstalling and reinstalling the driver that Windows is applying to the Code. Here's what you can do:

    - Go to your start menu
    - in the search bar, search for Device Manager. Click on Device Manager when it appears
    - Click on the arrow next to Sound, Video, and Game Controllers to display the list
    - Find the Code 49 and right-click on it, select Uninstall
    - The Code 49 should disappear from the list.
    - Unplug the keyboard, wait 30 seconds, and plug it back in
    - Windows should reinstall the drivers and the Code 49 should appear again in the list.

    Try it out again in FL Studio.

    Finally make sure that you are also testing with different USB cables and ports.

    Let me know how this goes!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited