Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Disable pitch bend on keystation 61

How do I disable Pitch Bend on a Keystation 61es. Seems that there have been a lot of people with the pitch bend sending signals on its own.
2 people have
this question
+1
Reply
  • Hi,

    Thanks for posting.

    Before disabling anything, you may just want to try blowing some compressed air through it. A lot of times it's just some dust building up inside and this should resolve it.

    If not, there's no way to disable pitch bend from the keyboard, but usually this is an option in your DAW. It's often located in the preferences or options under MIDI filter options.

    Let me know if this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Thanks for the reply. Air did not help at all. I dont see any way of filtering out pitch bend on Maschine software. Any ideas?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • 1
    Hey I figured out a way. Please spread this answer around if you see anyone else asking, because this took me 2 hours to fix.

    Get Bome's Midi Translator Classic: http://www.bome.com/products/miditran...

    Get MIDI Yoke: http://www.midiox.com/index.htm?http:...

    Install both. Restart your computer.

    In Bome's, set Midi In to your keyboard (Keystation 61), set Midi Out to "Out to MIDI Yoke: 1". Create a new translator preset. Edit it. Go to Incoming tab. Click Capture MIDI. Move your pitch wheel, then uncheck Capture MIDI. The MIDI message trigger should look something like:
    E0 00 pp
    (the "pp" stands all the values the wheel can move between, except the max value)
    Hit Apply.
    Also, enable MIDI Thru under Options.

    Open Ableton. Go to Options > Preferences, MIDI. Disable all the MIDI Yokes except for the MIDI Yoke 1 Input.
    (I also just leave my keyboard enabled there, but it should be orange which means it is being used in another application and can't work. That's because it is open in Bome's, which is why we are routing it through MIDI Yoke).

    That should be it. Your keyboard should now work and you have disabled the pitch wheel. I saved this as a preset in Bome's, and it opens by default every time.
    • Thank you so much for pointing me in this direction. I knew there was a way to get this done! I have used midipipe (another app) but only on mac and i knew there had to be something for windows.
      I tried your instructions but it seems that midiyoke does not work for windows 7 64bit.

      so i found another solution:
      -Installed Midi Ox (not midi yoke): http://www.midiox.com/

      -Installed LoopBe1 (the free version) : http://nerds.de/en/loopbe1.html
      I used this instead of midi yoke, this is just a virtual midi port that runs on your computer. the limitations to this free version i think is that you can only use one port.

      - in Midi OX go to Options-midi devices, select you keyboard as input, and loopbe1 port as output.

      go to options - Midi filter, on the left list select Pitch bend, and most importantly on the bottom list select "filter out data as well as display".

      Now on your DAW's instead of selecting your keyboard usb ports, select loopbe1 midi and select the first channel or port if necessary.
    • Nice! Thanks for sharing your solution. I'll try that out on the next PC I fix this on.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • control select- 34 (or whatever the pitchbend is numbered without the letter)
    control assign- 255 (000- on the keypad)
    for keystation pro 88
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated