Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Driver m-track 2x2 fails

Hi, I ́ve got a very frustrating problem with driver for M-track 2x2 (c-series) Setup. Always I am trying to install the driver it writes after short time of installing that "M-aduio M-track 2x2 1.0.6 Setup wizard ended prematurely. I was looking for solutions and trying everything i found - still doesn ́t working. Will you help me please? :) my Windows is 7 /64bits
4 people have
this problem
+1
Reply
  • Hey Filip,

    Thanks for posting!

    Sorry to hear you're having trouble installing the driver. It sounds like you are receiving a system error message from your computer when this occurs. I took a look at this specific error message and it looks like other users that have had trouble with installations had success after performing a clean boot into their operating system. The following article will walk through booting your computer in this way as well as how to boot normally back into your operating system after the installation.

    How to perform a clean boot in Windows

    Try that and let me know if you are able to install the driver successfully. You also mentioned in your post that you've tried some troubleshooting yourself - what exactly have you tried so far?

    Let me know!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned