I’m kinda annoyed - COME ON ABLETON, JUST WORK!

Failed to open the audio device "m-track quad asio driver."

Hi. I recently got M-Audio AV30 speakers, and the M-Track Interface. I've plugged it in with USB, and the speakers into the back, and I've installed the ASIO driver. However, when I try to select it in Ableton (Live lite 9 - The one that comes bundled with Alesis keyboards), I get the error message: Failed to open the audio device "M-Track Quad ASIO Driver."

I've uninstalled and reinstalled both the ASIO and the default windows drivers, anyone else have any ideas?

Also, should I be posting this here, or on an ableton community website?
1 person has
this problem
+1
Reply
  • Hi Luke,

    Thanks for posting. I'd be happy to help!

    Have you tried any other software with the M-Track, even something like an internet browser or music player?

    Do you have the M-Track Quad, an M-Track, or an M-Track Plus? There are actually two "generations" of M-Track and M-Track Plus plus the M-Track Quad, all with different drivers. You can confirm which one you have here:

    http://m-audio.com/products/browse/ca...

    (the "NEW" M-Tracks are also known as the MKIIs)

    Then, you can get that driver from the following page, in the "USB Audio and MIDI Interfaces" category:

    http://m-audio.com/support/drivers

    Also make sure that you're connected directly to a USB 2.0 port. No hubs or adapters. You may even want to try other ports and another USB cable (less than 6ft or so).

    Let me know and we'll figure it out!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Hi, I have the exact same problem with the M-Track. I downloaded the corresponding drivers, reinstalled it multiple times, checked it on all USB ports, and the error still persists. It's one of the 'new' M-Tracks, MKII, but Ableton just refuses to recognize the ASIO driver. I have no idea what to do next.
    • For me, it turns out that I was downloading the driver for the original M-track, where I have the MKII, like Dan suggested. I know this sounds ridiculous, but are you sure that you have the MKII? I found the website and packaging a bit confusing, and I'd thought I had the original. I believe that the original is black, and the new one is silver.
    • I have M Track Plus, Windows 10 Pro, and Instaledl M-Audio M-Track Series Windows_1.0.6.exe. Everything worked perfectly until I installed the latest update of Windows 10. After that, I no longer able to record audio anymore. I can only hear audio. The same is true in a notebook with Windows 10 Home.
      After making all sorts of maneuvers to try to get out of these problems, my conclusion is that drivers no longer work correctly in Windows 19. Is there scheduled updates drivers?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Hi is the device showing up in the audio control panel?
    If so, then maybe try with another audio program like audacity. It that does not work, then post on ableton forums or contact their support
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated