Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Firmware version of device not compatible with version of Preset Editor

Whenever I try to send Global Settings to the controller from the Preset Editor, or Retrieve a preset from the controller to the Preset Editor I'm shown the error message: 'The firmware version of your device is not compatible with this version of the Preset Editor. Visit http://www.maudio.com for the latest firmware updates.'

However I can assure you I have downloaded both most up to date versions of the Firmware and Preset Editor from the maudio website.

Would greatly appreciate the help, Thanks guys!
1 person has
this question
+1
Reply
  • Hey Elmo 3,

    Thanks for posting!

    Sorry you're having some trouble with that! Which M-Audio controller are you using?

    I understand that you've downloaded the firmware update but did you install the latest firmware version onto the controller? The firmware updater application will walk you through the process of updating the firmware on the controller as well as show you which firmware version the controller is currently using when the update is complete.

    Be sure to install the firmware onto the controller and verify the version with the updater app. Let me know how that goes!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Thanks for the help, I'm using the Code 25.This is most likely the problem, however I followed the installer steps and double checked them on the PDF Instruction file supplied. I must have only downloaded the update for the laptop but not the controller itself, but I don't see any instructions to individually update the controller.

    I have downloaded the update multiple times now and one thing I have noticed is that once I have downloaded the update while already having it on the laptop, I'm given the option to Remove or Repair it. However at this point the Firmware version displayed is v1.0.4.2 and not v1.2.3 (most recent), despite clearly downloading v1.2.3 every time. This leaves me to believe the controller itself is still running a previous version.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Hey Elmo,

    The firmware version for the Code itself is 1.0.4.2. Version 1.2.3 refers to the version of the updater application. I understand how that could be a little confusing but if your Code is saying it is running firmware 1.0.4.2, you are currently up to date!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • This reply was removed on 2019-04-28.
    see the change log