Help get this topic noticed by sharing it on Twitter, Facebook, or email.

How do I use my M-Audio Code 49 with Bitwig?

I'm on Ubuntu so Bitwig is the only DAW that works... And it doesn't work with my newly-purchased M-Audio Code 49. How can I get it to work?
2 people have
this question
+1
Reply
  • Corey S (Official Rep) May 18, 2016 19:54
    Hi,

    Sorry you are having trouble with that.

    The Code is only supported for use with Windows and Mac operating systems:

    M-Audio Code Series - System Requirements

    It relies on drivers that are pre-installed on Windows and Mac. I'm not sure if the same or similar drivers are installed on Ubuntu so i can't guarantee this will work.

    You should have some sort of Preferences menu in Bitwig where you can select MIDI In and Output ports or setup a controller. You'll need to find the Code here. If you do not have the Code available as an available MIDI port, that's likely because the keyboard is not working with this type of operating system.

    Let me know if you have any questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Hi,

    I've actually got it to work in part with Renoise, so the drivers aren't at stake. I read somewhere that Bitwig has scripts that it uses to communicate with controllers, but one hasn't been made for it. I found the thread : http://community.m-audio.com/m-audio/... You answered to it but I don't really understand how to apply the answer in the software.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Hi Corey. I read a comment on another thread about this. And i got midi working, but not MAc Hui Pro. You mentioned something to choose port 3 with Mac Hui Pro. Inside Bitwig there are no settings for ports, my question is: where do i choose port 3 for Mackie/Hui ?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Hi Zutko,

    Yes, whenever assigning a Mackie/HUI device with the Code you should use the 3rd available port. On a mac this will be labeled with Mackie, but with Windows it will appear as MIDIIn3 and MIDIOut 3. See the picture below:



    Go to Preferences and select Controllers to set up the controller and add the Mackie MCU Pro. Then, choose the ports as pictured in the image above.

    I hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited