I can't get M-Track to work with 48000 sample rate setting under Windows 10

After I switched from Windows 8 to Windows 10 I can't get M-Track to work with 48000 setting.

After I choose 48000 sample rate in M-Audio Device Setings from the tray, the device becomes unfunctional.

Symptoms are:
- apps show error when trying to record (Audacity wants me to 'check device settings' and project sample rate')
- in properties window for M-Track the Advanced Tab is missing (that's where I should be able to pick sample rate and bit depth value)
- the mode in which I should hear sound input through the speakers does not work (I can select it, but there's silence)

When 44100 value is selected in M-Audio Device Settings, all of the above work properly (but then in the Advanced tab all the audio depth options are for 44100 sample rate only).

I tried to reinstall driver in Windows 8 compatibility mode, but it didn't help.

What can I do :( ?
1 person has
this problem
+1
Reply
  • Corey S (Official Rep) July 05, 2016 20:52
    Hi,

    Please uninstall all M-Audio drivers from your system and run a ccleaner:

    CCleaner

    - Open CCLeaner
    - Click Registry
    - Click Scan for Issues
    - Wait
    - Fix Select Issues
    - Click Yes to create a ‘backup’
    - Click Save
    - Click Fix All Selected Issues
    - Run Steps 3-9 two or three more times until there are no issues found.
    - This should have cleared out unnecessary files that may have been causing any conflicts.
    - Reboot your computer

    If you have the M-Track Original (please double check this!) only install the driver below. Do not use a compatibility mode. This is not necessary:

    M-Track - Windows 10 Driver

    Please note, the sample rate should only be changed from the M-Track Control Panel, not the Windows Sound Preferences. After choosing your sample rate in the control panel, make sure to choose the correct sample rate in your software :

    https://www.youtube.com/watch?v=LzZxJ...

    You should also note that Audacity recommends 44.1 when using their software.

    I hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • 1
    Thank you for your reply!

    It didn't help, but it got me trying stuff and I found a solution.

    What I discovered:
    - both the problem and the solution I found are 100% replicable (after each clean install of the driver the problem will come back and the solution will work)
    - it works exactly the same on another Windows 10 machine.

    ...so I bet this must be a bug within the driver.

    The solution I found goes like this and needs to be followed EXACTLY as described:

    1. Set sample rate in M-Audio window to 48000.

    2. Open Sound properties with list of Recording devices.
    (due to 48000 setting M-Audio window won't grey out)

    3. Change sample rate to 44100 in M-Audio window.

    4. Enter Properties for M-Audio device.
    (the Advanced tab is visible, but do not enter it yet!)

    6. Change sample rate to 48000 in M-Audio window.

    7. Now enter the Advanced tab - 48000 options are visible now. Select one and go with OK.

    8. After this procedure is done, the Advanced tab is never again gone and all works as it should.

    And it is the only way to make it work!
    It was a fight between M-Audio window settings getting greyed out and the Advanced tab not being visible when 48000 setting is selected.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited