Legacy Firewire drivers for El Capitan

Please address the driver issue of Legacy Firewire products working in El Capitan.

This kind of support is unacceptable. I have hardware from MOTU that is older than my Firewire 410 and the drivers are still supported. I think it's a bit unfair to your customers if we all have fully functioning units that we paid for that are now basically paperweight... These kind of cases are exactly the type of material I'm compiling for a presentation i'll be doing at AES on industry warranty practices next year, and I'll make sure to name check your brand several times and mention how you treat your customers.

Regards.
11 people have
this question
+1
This topic is no longer open for comments or replies.