Help get this topic noticed by sharing it on Twitter, Facebook, or email.

M audio bx5a Buzz/Hum - Replaced 2 caps (6800UF) in each speaker, still hums in one speaker (no sound) but other speaker sounds great.

Love these speakers but one of the pair started humming then the other ones. I installed 2 new 6800UF caps in each speaker. One speaker sounds great, the other one has loud hum and the connection with the LXR connection. Also no signal goes through the speaker...just this loud hum/buzz. Any other solutions out there? Hate to throw these guys away if there is a good fix to the one speaker hums along. Something else inside to change? This is not a ground loop, I have checked all of that. Suggestions?
1 person has
this question
+1
Reply
  • Eliza (Official Rep) March 09, 2020 19:53
    Hey Tony,

    Thanks for posting!

    Component level troubleshooting can't be handled here on the forum. I would recommend contacting our support team for further assistance. Here are a couple of options that you could choose from:

    • Submit a Warranty or Service Inquiry with our Technical Support team by logging onto the M-Audio Support Page. Select Warranty or Service Inquiry from the drop down menu. This will not require a support code.

    or

    • For faster support, call or email your nearest Support Office or International Distributor. Select your country to find the nearest office.

    Make sure to reference or link to this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited