Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m amused

M-Audio Keystation Pro 88 and iPad not working via USB

Hello,
I’m having trouble with my station. Has been using it fine for more than two years and stopped working.
Is a M-Audio Keystation Pro 88
IK Multimedia iRig Midi 2
iPad (using iGrand Piano)

I will explain with detail.

Suddenly the iRig Midi 2 blue light is not lighting and the system won’t work meaning that is not receiving Midi data. The iPad does sounds with the software but when I try to control it with the keyboard there is no sound.
The keyboard’s knobs have not been touched since is not needed. I use channel 1 in Midi but tried changing just in case and nothing. Have rebooted everything. Have used other Midi cables between the keyboard and the iRig Midi 2 and nothing. I also tested the Midi data reception with an app called Midi Wrench and nothing. Also changing Midi channels and Omni.

No tutorial videos haven’t give me answers.

Then I stopped using the iRig Midi 2 (just in case is broken and causing the problem) and tried with USB out of the keyboard. If I use it on a laptop with Garage Band it will work! It will controll it.
But I must use the iPad with the iGrand Piano for my needs (as usual). So I connected from the keyoboard’s USB out to an original Apple adapter from USB (female) to Lighting for iPads (and iPhones) and it will not work on either. This expensive adapter from Apple has on one side two inputs: one USB in (for the keyboard) and a female Apple Lighting connector (so I plugged an AC cable to it to keep power into the iPad so the iPad won’t use power from the keyboard’s USB port). And on the other side of this adapter has a normal Lighting connector to plug in to the iPad.
This didn’t worked! And I would have swore it would. I also tried with an iPhone 11 and didn’t either so the iPad is ok.

When I plug the whole set up to the iPad a message appears in its screen saying:
“ THE DEVICE CAN NOT BE USED,
Keystation Pro 88: the device connected requires too much power”

This shouldn’t be since the iPad (the device) is being fed through this Apple adapter via AC. I still tried pluggin in different orders and sometimes unplugging the AC and done all tests. But the keyboard won’t send USB data to an iPad.

I read the Keyboards manual and don’t find any help. Talked to IK Multimedia and Apple and don’t know since the message is given by the M-Audio Keyboard.

What else can I do ?
1 person has
this question
+1
Reply