Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m confused

M-Audio M-Track 2x2 driver not being installed as device

Hi, I recently downloaded a driver program to fix some issues I'd been noticing unrelated to this, and after i restarted my computer my 2x2 was no longer being detected as an audio device. I have reinstalled windows and tried to reinstall the driver to no avail, all the files are where they should be, but during the install it doesn't present the dialogue box for installing a new audio driver.

My hardware is working (when i unplug and replug the device I hear my speakers pop), I have tried multiple cables and it still does not detect my 2x2. Does anyone have any advice?
1 person has
this problem
  • Hey Sean,

    Thanks for posting!

    It sounds like whatever application your ran to fix those issues on your computer has affected your USB root hub's ability to connect to devices and handle hardware drivers.

    I would recommend testing your M-Track with another computer to make sure that it is working properly. If you do find that it does work with another computer, I would recommend resolving what ever might be happening with your first computer.

    I hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated