Help get this topic noticed by sharing it on Twitter, Facebook, or email.

M-Audio M-track 2x2M not recognised on Macbook Pro

Hello!

I just bought a M-Audio M-track 2x2M and now trying to connect it to my Macbook Pro (El Capitan using Logic Pro X). My computer won't recognise the device at all (not even shows up in system preferences). I have tried it on three different Mac computers now and none of them will find my M-Audio M-track 2x2M.

PLEASE HELP! Thank you
1 person has
this problem
+1
Reply
  • Hey Fredrik,

    Thanks for posting!

    Sorry you're having some trouble with that! Let's make sure your M-Track is connected properly. The USB-C end of the M-Track's cable will click slightly when it is seated properly. Trying with other computer is definitely a good troubleshooting step but I would also recommend testing with a different USB cable and avoid using any USB hubs or adapters when you connect the interface.

    If you've tried that and you are still unable to use the M-Track as an audio interface, this sounds like it may be hardware related. Warranty and non-warranty claims cannot be handled here on the forum but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service Inquiry with our Technical Support team by logging onto the M-Audio Support Page. Select Warranty or Service Inquiry from the drop down menu. This will not require a support code.

    or

    • For faster support, call or email your nearest Support Office or International Distributor. Select your country to find the nearest office.

    Make sure to reference or link to this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated