This topic was merged into another on Tue, 08 Oct 2019 13:17:35 +0000 Click here to see the authoritative topic.
Help get this topic noticed by sharing it on Twitter, Facebook, or email.

M-Track 2X2M Audio Device Monitor failed to start

Hello, I have a question about installing the audio interface driver.

You have now purchased a model called M-Audio M-Track 2X2M.

During the installation of this audio interface driver, it appears that you cannot continue to grant permissions as shown in the picture.

1. I downloaded the appropriate driver for my operating system from the site.

2. When installing the driver on the site, tell them to connect to the audio interface and the computer.

3. So I hooked up with the computer. The audio interface power is turned on.
However, they say the device driver software cannot be installed.
(This is a USB-C type, and I did so because I said I could plug it into a USB 2.0 port on my computer.)
It's the same problem if you try another port.

4. You have successfully installed the downloaded driver.
The installation goes smoothly and at the end comes the words in the picture.

5. When I went to the Device Manager, there was no problem with the USB connection driver.
You can try connecting other devices to USB.

6. I have finished updating Windows 7 64bit
The mainboard, chipset, and other driver updates were all up to date.
But the same problem happens.

7. Based on the driver file information for the audio interface that failed to install,
It says 'Digital unsigned'.

8. However, the installation file properties indicate that the digital signature is valid.

9. All updates on my computer are complete. However, it cannot be installed.
If you connect USB, the device driver software installation fails, and if you proceed with the driver installation,
Failed to start service 'm-track 2x2m audio unit monitor'.
Verify that you have sufficient privileges to start system services.
It says.

Please. Is there a solution?

I think this has been going on for almost three years, so why hasn't it been solved yet?
And why is M-Audio the only problem with other brand products and why isn't it solved yet?
I understand that Apple had this problem.
Currently, the Apple company has informed customers of the perfect solution.
But why can't we do it here?
Here's always the same answer. There is no new solution.
If the driver installation is not working, how is it supposed to be installed?
Take responsibility for saying, 'We will find a solution.'

1 person has
this problem
+1
This topic is not open for comments or replies.