M-Track 2X2M VGA display problem

Hi there,

When connecting my M-Track 2X2M to the USB port on my laptop it is causing the display monitor to disconnect. After a few seconds the monitor reconnects and then disconnects again. This cycle then repeats every few seconds.

The monitor is connected through the VGA port.

This problem doesn't happen with other USB devices.

I am running a Dell E5430 on Windows 10 64-bit and Intel HD Graphics 4000.

This problem confines me to my smaller laptop screen when I want to be using an extended desktop. Any ideas on how to fix this?

Edit: I have tried updating my display drivers but they are currently up to date.

Many thanks,

Mike
1 person has
this problem
+1
Reply
  • Hi Mike,

    Thanks for posting!

    Very strange. This will happen with the M-Track connected to any USB port on the computer? Are you using any USB hubs? Any other USB devices connected at the same time?

    Is the laptop connected to power or running on battery?

    Try connecting the M-Track to the PC first, allow it to connect fully, and then connect the monitor. Any difference?

    There could be a possibility that this is an IRQ conflict between the 2 cards and/or power issue. Start by checking for an IRQ conflict using the article below:

    http://www.helpwithpcs.com/upgrading/...

    I hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated