Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

M-Track Eight clicks and pops in playback Windows 10

First of all, sorry for my english, I'll try to explain myself anyways:

I have an M-Track Eight USB interface for almost 3 years. I haven't used it for a while (like a whole year) and now I have this new PC (AMD Ryzen 7 2700x, 16gb RAM DDR4 2666, R9 series Radeon), and everytime I use the audio on the PC (it can be Cubase or YouTube or some game), I have a lot of clipping, popping, clicks, and audio artifacts.
After using it for a while (around 5 minutes) those noises dissapear, but if I stop using the audio for 2 of 3 minutes and want to start playing something again, the noises come back.
I haven't tried the interface in another computer or OS, but I'll try today in my Windows 10 notebook (A 2019 Lenovo Legion).
I have noticed M-Audio don't release a drivers update since 2015, and also have noticed a lot of M-Audio interfaces are having problems with Windows 10.
Idk, maybe someone went through the same and have a solution out there? I couldn't find any solution searching with google.
1 person has
this problem
+1
Reply
  • Hey Delirio,

    Thanks for posting!

    Sorry to hear that you are having trouble! Clicks and pops usually indicate that your processor is being overwhelmed by the audio stream. What are your sample rate and audio buffer size set to?

    I have seen issues like this happening for AMD processors as the M-Track drivers are optimized for Intel Core. My advice would be to lower your sample rate (no higher than 48KHz) and raise the buffer size.

    If you are still hearing clicks and pops, test the interface with a different computer to see if the issue persists.

    Try this and let me know how it goes!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated