Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m Frustrated

M-track overpowers (red light) as soon as I plug it into my computer. Cant record anything.

I am using a 1 channel m-audio m-track on a 2012 Macbook Pro, running Logic Pro X. It worked fine a few months ago, but when I got home from vacation, I plugged it in and the dB indicator immediately maxed out. I tried recording a voice track or a guitar and I'm getting little to no signal into Logic and it sounds distorted, like a really low buzz. Help!
1 person has
this problem
+1
Reply
  • Hey Lucas,

    Thanks for posting!

    This sounds like it may be hardware related. Warranty and non-warranty claims cannot be handled here on the forum but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service Inquiry with our Technical Support team by logging onto the M-Audio Support Page. Select Warranty or Service Inquiry from the drop down menu. This will not require a support code.

    or

    • For faster support, call or email your nearest Support Office or International Distributor. Select your country to find the nearest office.

    Make sure to reference or link to this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated