Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m sad

M-track crackling on fl studio 11 (usb midi problems?)

My gear:
Lenovo G505 laptop
Akai MPK Mini
M-Audio M-track
at2020 mic (xlr)

My m-track and mpk mini are connected to my laptops usb 3.0 hubs. My mic is also connected to the m-track. I open up Fl studio and i select the updated windows 8 m-track driver. When I hit the pads on my midi, my instruments are all distorted and crackle-y. Including vocals. I use headphones on the m-track. Ive been troubleshooting for days now, updating my drivers, uninstalling and re-installing programs, cleaned up my pc to free up space, tried all my usb hubs, disabled and enabled the audio hardware on my control panel, changed buffer rates and sample rates...nothing is working.

Do i have this problem because my midi is not connected directly to the m-track?
Is my computer too slow?

I am very new to all of this technical stuff, and I figured I missed something, or i messed up something on my pc (or fl) while troubleshooting. All help is greatly appreciated. If left out anything you should know, i will explain in more detail.

Thanks in advance!

Nelly
3 people have
this problem
+1
Reply
  • Nelly your troubleshooting steps have been spot so thus far. My initial thought would be that it could be related to your hub. These products were not "approved" for USB 3.0. Is it possible to try on another system and see if you get the same results. If not please take these optimization steps and let me know if the problem persists.

    *Open the Control Panel.
    *In Large icon View, click on Power Options.
    *Select the High Performance power plan. Click on the Change plan settings link.
    *Set the display's sleep time to Never.
    *Set the computer's sleep time to Never.
    *Click on the Change advanced power settings link.
    *Click on the + sign next to Hard Disk.
    *Click on the + sign next to Turn Off Hard Disk After.
    *Click in the value box; the text entry field will now be accessible.
    *In the text entry field, type Never.
    *Click on the + sign next to USB settings.
    *Click on the + sign next to USB selective suspend setting.
    *Double-click where it says Enabled and click on Disabled.
    *Click on the + sign next to Processor power management.
    *Click on the + sign next to Minimum processor state.
    *Type 100 in the Setting (%) text entry field.
    *Click Apply then OK.
    *Click Save Changes.
    *Close the Power Options window.

    This optimization prevents the computer from going into Sleep Mode, which can cause playback issues with audio interfaces. This will also prevent the hard drives from going to sleep, and disables USB Selective Suspend, which can cause pops and clicks during record and playback with USB interfaces when enabled.

    Thanks Nelly!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I’m excited
    I will try this out right now! Thank you for your response!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned