Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Mac not finding M-Track 2x2 C-Series

I moved my iMac to the other side of my room the other day. Once I got everything plugged back up my M-track 2x2 C-Series wasn't picking up on my iMac. The board is picking up my mic but my computer won't even pull up the M-Track as an audio option. It's getting power though the USB So I know it's working, and I've tried many USBs. I've gone though every fix guide on their website but nothing works.
1 person has
this question
+1
Reply
  • Eliza (Official Rep) March 23, 2020 22:15
    Hey Pates306,

    Thanks for posting!

    Sorry to hear that you're having trouble! You mentioned that you tried different USB cables. Have you also tried different ports on your computer? I would suggest testing the M-Track with a different computer to see if it registers.

    If not, then there is most likely an issue with the USB port's data pin. In this case, I recommend contacting the support team for repair assistance. Warranty and non-warranty claims cannot be handled here on the forum but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service Inquiry with our Technical Support team by logging onto the M-Audio Support Page. Select Warranty or Service Inquiry from the drop down menu. This will not require a support code.

    or

    • For faster support, call or email your nearest Support Office or International Distributor. Select your country to find the nearest office.

    Make sure to reference or link to this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated kidding, amused, unsure, silly