I’m excited

Mobile pre 2 working on El Capitan!

Yay! Finally managed to get it working! Just run in class complaint mode!!!! Here's what you need to do to bring it back to life.

1. Uninstall the Mobile pre 2 driver.
2. Reset NV Ram ( Press Option+CMD+ P R )
3. Shut down & Connect the device. Now restart. The device should be showing in your sound settings.

P.S : M Audio fast track 8R ultra drivers are installed on my computer. dunno whether this helped solve the issue! :)
1 person likes
this idea
+1
Reply
  • Hi,

    Thank you for sharing!

    As you may be aware, M-Audio was acquired by inMusic brands in 2012. The following products were not included with this acquisition, and will be marketed, sold, supported and serviced by Avid moving forward:

    • Fast Track
    • Fast Track C400
    • Fast Track C600
    • Fast Track Pro
    • Fast Track Ultra
    • Fast Track Ultra 8R
    • Fast Track USB
    • Mobilepre USB
    • Mobilepre
    • M-Box

    I'm sure current M-Audio users may find this helpful for their products, but anyone having trouble with their Mobile Pre should contact AVID if they require further assistance. For support or service on the products above, please contact Avid using the following channels:

    www.avid.com/support

    http://duc.avid.com

    Hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Hello

    My mobilepre was perfectly working on el capitan without me trying anything. I just upgraded my mac to el capitan and it kept working... until i decided to reinstall the drivers to see if it would stop the ground loop i had. well the only thing i managed to do is having my mobilepre not recognized anymore.
    What i dont understand is that it used to work.
    When I go to the system report, the mobilepre appears in the USB devices but not in the sound options. I tried your tip but it didn't change anything.
    I don't know what to do... Does it still work for you?
    regards
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Hi

    this worked for me too. Make sure you delete every 'mobilepre' file in the System and Library folders. There are 4-5 files in various places. Look in all sub-folders!

    It seems the mobile pre is plug and play with El Capitan, no driver support is needed.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • I've recently been trying to get this to work on my computer. I tried resetting the NVRAM, and it recognizes the device under System Report, but it doesn't show up anywhere else. I've been trying to get it to work in Logic, but Logic doesn't seem to recognize it. Any further suggestions?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly

  • I’m excited
    I am very happy to report that I am playing my guitar through Garageband, and outputting to speakers, via my old M-Audio (Avid) MobilePre USB preamp! I also found the dead end with the Avid drivers when I upgraded from Mavericks.

    I decided one last time to check out if there were any new drivers before I threw the old box away, and I stumbled across this post that WORKED!

    Simply delete the drivers! In System Preferences, right click on the MobilePre control panel and remove it. Search your hard dive for any other "MobilePre" files (I only found 1), and delete those. Though people have posted to zap the PRAM, I didn't need to. Restart the computer. MobilePre now shows up in my sound Control Panel as an input and output option. Sure, I've lost a couple of level controls, but no big deal... it works!

    Apparently, at some point Apple snuck in native support to El Capitan. I'm on MacOS 10.11.6.

    In Garageband, you will have to re-select the input and output. I'm afraid I don't have Logic so I can't test that.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • I’m happy
    Hmm.
    It looks like my problem is that the device is not showing up in the sound Control Panel. Seems as if this was also Antoine's problem from above. I am running 10.11.6, and the Mobile Pre is showing up in the System Report under the USB tab when it is plugged in, but that's the extent of the connection. No sign of it in the sound Control Panel or anywhere else.
    Thanks for all the help so far, everyone!

    Edit: I solved the problem. I just made sure the mobile pre was plugged in when the computer was off and started it up with it plugged in. Previously I had only plugged it in when the computer was already on.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited