Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

My M-Track 2x2 Non-MIDI has problems that I don't have a fix to.

My M-Track 2x2 Non-MIDI has problems that I don't have a fix to.
My AT2020 is being cut every second in streaming software (as heard in any of the clips here: https://www.twitch.tv/fooklife/videos)
My AT2020 sometimes simply doesn't work anywhere, but the interface still shows the sound bars.
For both issues I have tried every single possible fix there is on the internet. It has persisted over the last month. Any help would be greatly appreciated
2 people have
this problem
+1
Reply
  • Hey Jason,

    Thanks for posting!

    Sorry you're having some trouble with that! We can easily test the input of the microphone by turning the Direct/USB knob toward Direct. This setting will send the audio that is going directly into the M-Track from the microphone to the main and headphone outputs. If you receive a consistently clear signal, it's probably safe to say that the microphone and the inputs of the M-Track are working correctly.

    If that is the case, the problem lies somewhere within the software. If you are receiving audio dropouts, this is indicative of some strain on your computer's processor and it sounds like you will need to increase the audio buffer value in the software you are using to record audio. If you are not using software and inputting audio directly to Twitch, you can use the M-Track's control panel software. The control panel installs with the driver (search your computer for M-Audio M-Track 2X2 Control Panel) and use it to adjust the buffer:



    Increase this setting incrementally as increasing it too much can introduce latency (a delay) into your signal. I would recommend bumping up the buffer a little, closing the control panel, then testing the audio input. Repeat this process until performance improves. Be sure to turn the Direct/USB knob back toward USB so you can hear the audio being processed by your computer. I would also recommend closing all non-essential applications on your computer to give your processor the maximum amount of available resources to process the video and audio streams.

    I hope that helps!
    • Greetings! I have turned the knob to USB and I cannot hear anything through the main headphone port on my interface. The mic is set to default in windows and so are the headphones if it has any relevance. I have turned the mic gain knob to the maximum and still cannot hear anything coming from the mic. The headphones do in fact work, as it picks up the sounds coming from Windows and such.

      I have tried bumping up the buffer size, but to not outcome whatsoever. In case you wonder it did display that the hardware is connected and that I am in fact streaming.

      My interface does display the "green bars" when I am speaking into the mic, but Windows' sound settings bars do not move whatever I would do. In case you are wondering, I have done all the "fixes" I could find on the internet, but to no result.

      Here is a screenshot of windows settings: https://gyazo.com/5ad98c8d673d086fa7b...

      My headset mic (a different headset from the one connected in the interface) does work without any problems, putting all the blame on the interface, mic or some kind of windows issue, highly doubting the latter, as I have browsed the internet for days for fixes there.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned