Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m confused

no sound when linking m-audio fast track mk2 to logitech Z906 with RCA connector





I'm Chinese, more accurately, Taiwanese, so sorry for my poor English. My audio interface is m-audio fast track mk2, and my speaker is Z906 from logitech. As title, I just can't hear any sound when linking m-audio fast track mk2 to logitech Z906 with RCA connector; however, I can hear sound with my headphone, whose connector is 3.5mm, via 3.5mm to 6.3mm jack. What should I do to make my Z906 speaker and headphone have sound simultaneously? If can't simultaneously, my priority is Z906. Sincere thanks for people answering my question.
1 person has
this problem
+1
Reply
  • Hi,

    Thanks for posting!

    As you may be aware, M-Audio was acquired by inMusic brands in 2012. The following products were not included with this acquisition, and will be marketed, sold, supported and serviced by Avid moving forward:

    • Fast Track
    • Fast Track C400
    • Fast Track C600
    • Fast Track Pro
    • Fast Track Ultra
    • Fast Track Ultra 8R
    • Fast Track USB
    • Mobilepre USB
    • Mobilepre
    • M-Box

    For support, service, or updates on any of the products listed above, please contact Avid using the following channels:

    www.avid.com/support

    http://duc.avid.com

    Hope this helps you find an answer!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated