Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

On my M-Audio M-Track preamp, only one of the two mic jacks works. The other mic input is dead. What causes this?

I use the M-Track for recording my singing videos for YouTube. I had better quality when both mic inputs were working. Now only the left mic input works. The right hand one does not. I have tinkered with the controls-- gain-- and have different mics on both sides. The right hand one does not produce hardly any sound, although flickering lights on the control panel light up.
1 person has
this question
+1
Reply
  • Hey Bruce,

    Thanks for posting!

    This sounds like it may be hardware related. Warranty and non-warranty claims cannot be handled here on the forum but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service Inquiry with our Technical Support team by logging onto the M-Audio Support Page. Select Warranty or Service Inquiry from the drop down menu. This will not require a support code.

    or

    • For faster support, call or email your nearest Support Office or International Distributor. Select your country to find the nearest office.

    Make sure to reference or link to this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated