Help get this topic noticed by sharing it on Twitter, Facebook, or email.

USB C 3.1 port compatability

My brand new MacBook Pro which has only USB C 3.1 ports does not recognize the M-track 2x2M. Any suggestions?
1 person has
this problem
  • Eliza (Official Rep) June 10, 2019 13:05
    Hey Matthew,

    Thanks for posting!

    USB 3.1 is backwards compatible with USB 3.0 and 2.0. Since the M-Track is a class compliant device, the problem is most likely stemming from a physical USB connectivity issue.

    Are you using any USB adapters or powered hubs to connect the interface to your computer? If so, are they Apple certified? Have you tried using a different USB cable and ports on your computer? Have you tried connecting the M-Track to a different computer?

    Try this and let me know how it goes!
  • (some HTML allowed)
    How does this make you feel?
    Add Image

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned