Trouble with ZenCart related installation

  • Problem
  • Updated 3 years ago
  • Solved
The slideshow does not work on my page. I have a custom template where all modifications are made to tpl_main_page.php.

I have checked in languages/english/classic/define_main_page.php and there is no code or anything at all in this file. I cannot find an alternate define_main_page.php; this is a website set-up that I inherited from someone else and I have never configured Zen Cart before.

I have tried installing the following code into the main page banner on Zen Cart. Can someone please give me a step-by-step approach to get this module working. It seems like a good one. I would appreciate your help!
Photo of AniA

Ani

  • 1 Post
  • 0 Likes
  • confused and frustrated.

Posted 3 years ago

  • 1
Photo of Jacket

Jacket, Official Rep

  • 93 Posts
  • 8 Likes
Hi!

As you have a custom template with modifications to tpl_main_page.php, you should manually install Magic Slideshow where you want it.

1. Open the template where you want to add a slideshow.

2. Insert references to the JS and CSS files into your template, like this:

<link rel="stylesheet" type="text/css" href="/jscript/magicslideshow.css"/>
<script src="/jscript/magicslideshow.js" type="text/javascript">


(Please edit the filepath "/jscript/" depending on the location of the CSS/JS files on your server.)

3. Insert the following code into the location of your template where you want the slideshow to display:

<div class="MagicSlideshow">
<img src="example1.jpg"/>
<img src="example2.jpg"/>
<img src="example3.jpg"/>
<img src="example4.jpg"/>
</div>


More guidance for setting up and customising Magic Slideshow is available here:

http://www.magictoolbox.com/magicslid...

Thanks!