Can't order from Microsoft Store

  • 3
  • Problem
  • Updated 6 years ago
Microsoft's credit card validation service is broken. On two separate occasions over the course of a few months, I was unable to complete an order via the Microsoft Store. The only "help" Microsoft would give us was to check with the bank and try again. We checked with the bank/credit card companies a multitude of times, and all the information was perfect. We also tried creating a new Windows Live ID... a dozen representatives, and four credit cards later, it still didn't work.

Microsoft's CC fraud team would not call or email myself or our controller, nor would they allow this to be escalated further than their CC fraud team. We finally gave up and traveled quite a bit to physically pick-up the software; however, it is not always practical to run out to the store and waste a few hours of time. We should be able to order software at-will, on demand.

I am a 100% Microsoft guy, and always have been (and still am) a loyal supporter of their services and software; however, I am appalled at their inability to resolve this issue. It is my opinion that if they cannot resolve this issue for my company, and the others experiencing it, they should not provide their software online at all. It seems to be a system that works for their interests and not the customers'.
Photo of chris

chris

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 10 years ago

  • 3
Photo of Ryan Johns

Ryan Johns

  • 1 Post
  • 0 Reply Likes
This thread may be 4 years old, but I seem to be having the exact same issue. I've tried many different credit cards, many different IDs, and I quadrupled checked all my information. Calling them (upwards of 10 times now) has yielded no progress whatsoever. Like you said, they just keep telling me to check with my bank/credit card company. But there is simply no way that's the issue, not with 7 different credit cards. The ONLY way I'm able to place an order is by using a fake address. So it seems they have my address blacklisted for some reason. Why they're not able to see that in their system is beyond me.

I'm utterly baffled at the Microsoft support reps inability to solve this issue.