Changes to the question

Is the latest Mixmeister Fusion compatible with macOS High Sierra Version 10.13.1?

In order to preserve the promise of transparency and open communication, the change log records changes to topics made by both customers and employees. Anyone can dispute a change by clicking the "Dispute" link and entering additional details.


  • April 04, 2019 07:34
    Johan Guijt
    Change in reply by Johan Guijt to I won’t say compatible. You can work with Mixmeister Fusion, if you don’t mind it crashes several times in one hour. The Windows version is more stable. I like mixing with Mixmeister but on High Sierra it became a frustration, on my MacBook Air with 10.14 Mojave, Mixmeister won’t even start. That’s not where I Paid my money for!.

See all changes made to topics in this company