Help get this topic noticed by sharing it on Twitter, Facebook, or email.

MixMeister Studio won't install on macOS Catalina (10.15) - when will it be compatible?

It simply states it's not compatible with this version of MacOS and should contact the developer. I asked for technical support through MixMeister twice with two weeks in between, yet no response. I downloaded the latest version of MixMeister.

Does anyone have more info or maybe a way to work around this?
1 person has
this question
+1
Reply