Copy, Drag&Drop...Still Not Working

  • 5
  • Question
  • Updated 4 years ago
About 4 months ago there was a discussion on this topic. It still isn't resolved and I'm missing this feature. So, again, can anyone tell me why it doesn't work on my systems? PC1 = Win7x64 - PC2 = Vistax32-SP2. Using version2.1.1.1212 of MwB
I read all comments on different boards but still no answer on: why does copying or drag&drop does not work? There is no (or does not "popup") MwB-folder other than the installationfolder under ProgramFiles. Can't copy to/from Windows Explorer, any folder on the desktop or on the desktop itself. On both firewalls communiction for MwB is enabled and the service will start "Automatically". UAC is set to minimal (Win7) and disabled for Vista.
So....Anyone??

PS: has anyone noticed that uninstalling the program does not remove "all" settings, like security key, computername(s) and settings on the "other options" page?

THX
Photo of john.vandael

john.vandael

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 9 years ago

  • 5
Photo of sproket90

sproket90

  • 1 Post
  • 0 Reply Likes
i have same issue, worked fine until i upgraded to 2.1.1.12.12
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
There are different copy/paste features in the app. Do all of them do not work for you:

1. Copy a short text from one machine to the other.
2. Copy a huge text from one machine to the other.
3. Copy a single file from one machine (local folder) to the other.
4. Copy a small image from one app in one machine to the other (like mspaint)
5. Copy a big image from one app in one machine to the other (like mspaint)
6. Drag a single file from one machine and drop to the other machine.

Please note that the copy/paste drag/drop does not work on folder, multiple files and a network file.

Since this feature is all about clipboard hook, inter-process communication and networking, once the feature does not work, we would need to triage the problem in different areas:

When you copy a text from one machine:

(A). Is the clipboard helper process running? (try to click on the Mini-Log link on the Settings form to get the mini log, in the log there should be an entry like "Helper:123456" where the number should be non-zero which tells that the clipboard helper is working fine).
(B). There is a little blinking, blue dot on the app's system tray icon telling the that clipboard helper works fine in the that machine. When you do not see this, it means there is something wrong with the clipboard hook in the system. Some people have pointed out this is actually an issue with the operating system and the workaround is to restart the app.
(C). There is then also a little blinking dot on the app's system tray icon in the remote machine telling that the clipboard data has been received by the machine. If not there might be some problem with network connection between two machines.

There are also few areas that we can make some improvements to make this feature work better, hopefully we can add them to the next version.

Thanks!
Photo of videdit

videdit

  • 2 Posts
  • 0 Reply Likes
Does not work under Windows 10 for some reason. You had a nice explanation. It showed me that the I should be checking the blue dot blink on the icon for the copy buffer to update. This works on Windows 7 but not on Windows 10.

Ah - found that if you combine turning off the UAC with a forced kill and restart of the helper exe works OK.
(Edited)