Don't switch keyboard/clipboard focus until I've clicked somewhere

  • 1
  • Problem
  • Updated 4 years ago
Right now, Mouse without Borders switches the keyboard focus to whatever screen the mouse cursor has moved to, even if it hasn't clicked anywhere on that screen, which is really annoying and not the typical windows user experience.

In windows, you can move your mouse wherever you want, but whatever you clicked on last is what still has the keyboard and selection focus.

This happens to me all day long, every day while using this product, I'll click on some text box or somewhere where I want to type, like a web browser URL entry box, and then I'll move my mouse out of the way, so that I can type -- sometimes that ends up on a different screen without thinking about it -- but I never clicked on that screen -- normally, in windows multi-mon, this would work fine.

But mouse without borders switches keyboard focus as soon as the mouse comes onto the second screen, even if you don't click anywhere.  The keyboard focus should not be moved to the alternate screen until you've clicked somewhere.

This should also be the case for Ctrl+C / Ctrl+V, and other hotkeys, as well as, dragging a selection (i.e. if I drag a selection box and move the mouse off the screen (even just a hair -- by habit), normally, it would just clip at the end of the window in regular multi-mon, but the mouse gets stuck in "pressed" down mode on the primary monitor until they click again (this causes all sorts of weirdness when trying to select things).

If the project was open source on GitHub, I'd offer to look at implementing these requests myself, let me know if you need any help with the issues or any more information describing them.

Thanks,
--Mikey
Photo of Michael Jensen

Michael Jensen

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Clint Schaefer

Clint Schaefer

  • 2 Posts
  • 0 Reply Likes
Simple solution: Enable the Other Options setting "Disable Easy Mouse" and then it'll require you to hold Control in order to switch machines.

I had the same issue as you with accidental switching and it caused more problems than what having multiple monitors alleviated. By requiring the simple depressing of Control in order to break the screen border you'll no longer have those accidents, and trust me you'll end up pressing control simply by force of habit in no time.

Alternatively you could just tell Windows to "Hide Cursor While Typing" (in the Mouse settings), which would alleviate the need to even move the cursor out of the way in the first place. :)
(Edited)