Mouse Without Borders installation has ended prematurely.

  • 13
  • Question
  • Updated 3 years ago
I downloaded the msi file and during the installation I got this error :

"Mouse Without Borders installation has ended prematurely.your computer has not been modified.to install mouse whitout borders as a later time please run the installer again"

Tried all ways and nothing worked.
Using Win7(32bit), Core 2 Duo, Trend Micro AV.
Any idea what services/programs might be causing it not to install?
Photo of astrocon

astrocon

  • 4 Posts
  • 1 Reply Like

Posted 9 years ago

  • 13
Photo of TobieFysh

TobieFysh

  • 3 Posts
  • 1 Reply Like
Install wants me to install .net Framework 2 but unable to as Windows 7 already includes it.....
Photo of TobieFysh

TobieFysh

  • 3 Posts
  • 1 Reply Like
To fix for me I ran CMD elevated (I'm an Admin with UAC turned on.
Then switched to directory that the MouseWithoutBordersSetup.msi file was in and ran it via the command line.
Photo of Fanaticz

Fanaticz

  • 2 Posts
  • 0 Reply Likes
Didn't work for me, same Message as Astrocon. Tried TobieFysh "fix" without success. I don't have UAC turned on and my User is the only Administratoraccount on this machine.

I have .net Framework 4 installed and an Win7 64bit system
Photo of astrocon

astrocon

  • 4 Posts
  • 1 Reply Like
Sorry, didn't work for me too.. still wondering what could have interuptted the installation. :/

besides, did try to go to safe mode(with installer service activated) to try to install. failed with the same result.
Photo of SnapJag

SnapJag

  • 6 Posts
  • 1 Reply Like
I had a problem installing too. You may want to try the recommended fix to Enable the Firewall service. It worked for me. Happy now.
Photo of LeNurB Taps

LeNurB Taps

  • 1 Post
  • 0 Reply Likes
Enable the Firewall service. It worked for me too
thank
Photo of TobieFysh

TobieFysh

  • 3 Posts
  • 1 Reply Like
Sorry that it didn't work for you Fanaticz, both my systems are 32 bit so wonder if that is where the stumbling block is, I'll now return to lurking :-)
Photo of Fanaticz

Fanaticz

  • 2 Posts
  • 0 Reply Likes
It works on my Notebook, which also runs a 64bit Win7. Same with my other Machine. It's just this one. Maybe I should try it with a fresh win7 installation, this ones a bit old...

Still, thanks for answering :-)
Photo of Juan

Juan

  • 1 Post
  • 3 Reply Likes
there seems to be a problem with the installer, on my win7 x64, had to unpack msi manually (msiexec /a mousewithoutborders.msi TARGETDIR=c:\temp /qb) and then tun the installutil to install the windows service (mousewithoutborderssvc.exe).

It is working on my machine, but the program is still a little rough on the edges, nice features though.
Photo of SnapJag

SnapJag

  • 6 Posts
  • 1 Reply Like
I had a problem installing too. You may want to try the recommended fix to Enable the Firewall service. It worked for me. Happy now.
Photo of Edwan

Edwan

  • 1 Post
  • 0 Reply Likes
Wow Juan, it worked for me ! thanks !
Photo of astrocon

astrocon

  • 4 Posts
  • 1 Reply Like
+1 for Juan..

method works. just that to expand a little on the installutil part, (not exactly something that comes naturally without google :p)

installutil.exe is located in the following folder..

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

for the inelegant method, copy the mousewithoutborderssvc.exe to that folder and run the following)
(installutil.exe mousewithoutborderssvc.exe)

got this up and running. thanks loads!
Photo of Scott Baker

Scott Baker

  • 1 Post
  • 0 Reply Likes
Did what astrocon and Juan suggest but after instal;ling the service nothing really seems to happen or be there - is there some other step? Hopefully they will fix the installer.
Photo of SnapJag

SnapJag

  • 6 Posts
  • 1 Reply Like
I had a problem installing too. You may want to try the recommended fix to Enable the Firewall service. It worked for me. Happy now.
Photo of astrocon

astrocon

  • 4 Posts
  • 1 Reply Like
after you got the service installed, run the mousewithoutborders.exe file, the cute blue welcome screen should start and you should be able to get it running.
Photo of asd

asd

  • 1 Post
  • 5 Reply Likes
Hi i found the problem.
Just make sure you have the Windows Firewall service enabled and running. After the installation is done you can disable it again.
Photo of User_Zero

User_Zero

  • 1 Post
  • 0 Reply Likes
I did exactly this and it worked for me.
Photo of Chip Stalega

Chip Stalega

  • 1 Post
  • 0 Reply Likes
Norton won't let me turn on Windows Firewall?
Photo of SnapJag

SnapJag

  • 6 Posts
  • 1 Reply Like
Fabulous. Thanks. Turned ON the windows firewall service and it installed. Then turned it back off. Kind of funny how this is required. But it's a viable workaround.
Photo of cln3100

cln3100

  • 3 Posts
  • 0 Reply Likes
Also noted Windows Firewall was the issue, if you're using WI logging (i..e msiexec /i .../l*v), the error will be (cont'd on next post)
Photo of cln3100

cln3100

  • 3 Posts
  • 0 Reply Likes
CustomAction WixExecFirewallExceptionsInstall returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

Enable Windows Firewall service and it'll be all good
Photo of oilsbypeter

oilsbypeter

  • 1 Post
  • 0 Reply Likes
After I did ALL the above to no avail... I turned off my Kaspersky, turned on Windows Firewall and pasted the application into C:\Program Files (x86)\Microsoft Garage . Then I ran the installer from a command line via "RUN" and got the Blue Box to install like it did without issues on my other two machines. A lot of work to get something that I have used with my Linux systems (Synergy) with no issues at all.
No there is a trick to the moving of the mouse. Make sure that you put your main machine (Center) in the middle in order to go to the left or right machines. Otherwise, you mouse will not appear on the center machine. Now I can work on the Center machine and move right to control the right machine or left to control the left machine.
Photo of ksm

ksm

  • 3 Posts
  • 1 Reply Like
Windows firewall is ON, but still can not install MouseWB :(
Photo of cln3100

cln3100

  • 3 Posts
  • 0 Reply Likes
Try verbose logging, the command will look like (Run > CMD):

msiexec /i "FOLDER_WHERE_ITS_LOCATED\MouseWithoutBordersSetup.msi" /l*v C:\MWoB_Install.txt

Go find the MWoB_Install.txt located on your C:\ drive...if it didn't write or gave some permissions issue writing to that directory, you have some permissions issues, try another directory such as your desktop.

The install log should give you some feedback on what's the problem. Just do a find for "return value 3" and you should be able to get an error message above the syntax.......then google it. You've now become a power user...use this power wisely.
Photo of fearlessfife

fearlessfife

  • 1 Post
  • 0 Reply Likes
I managed to get the service installed on a win 7 x64 machine using the installutil.exe method. Now the program exe will not run or start the service. Tried manually running the service and then the exe still nothing. Oh well, Synergy still works wonderful right from the install.
Photo of ksm

ksm

  • 3 Posts
  • 1 Reply Like
shame on me ... I was working with CMD in user, not admin mode.
Photo of Mootaz Dinana

Mootaz Dinana

  • 5 Posts
  • 0 Reply Likes
Running the MSI via this command:

msiexec /i "WHERE-YOU-HAVE-IT-DOWNLOADED\MouseWithoutBordersSetup.msi" /l*v WHERE-YOU-HAVE-IT-DOWNLOADED\MWoB_Install.txt

from an elevated CMD window solved it for me, i.e. Start->write CMD-> right click on CMD icon and select run as administrator-> replace WHERE-YOU-HAVE-IT-DOWNLOADED with the directory where you downloaded the msi file and paste in the black CMD window you just opened and Voila!
Photo of Yves Van Opstal

Yves Van Opstal

  • 1 Post
  • 1 Reply Like
I just had to enable my firewall and it installed no problem ... (set Windows Firewall service to automatic)
Photo of Peter

Peter

  • 1 Post
  • 0 Reply Likes
It is that stupid.
Did an fresh install on two PC.
On each of PC the program asks "Have you already instaaled mouse without Borders on another computer".
Guess what I and each other person would do? I would said "Yes".
Ha ha.

The program demands for a security code, you should find it in "settings" on each other side. But there is NO code.

Guess what, you have to say NO!
That stupid.
Go to the first PC and say No. This will give you the security code.
Enter this code the second PC in.

OO. Guys, doing so , you will never throw me back again from Mac to Windows.
Photo of Tony More

Tony More

  • 1 Post
  • 0 Reply Likes
I'm having the same installation problems initially reported by others. Under normal circumstances, I might be willing to "experiment" and try all the recommended work-arounds. However, I just don't have the time and patience right now. So although I had high hopes, I suppose I'll just have to wait for this utility to "be ready for prime time."
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
Have you tried the latest version? - https://getsatisfaction.com/mouse_wit...

We have over 10k users running this tool internally here in Microsoft without any issue, plus half-million downloads externally. So I believe this issue happens with a very small number of users where mostly there is something configured in the machine. You might want to help us find out why!
You can install the latest version with logging option (run as Admin):

msiexec /i "WHERE-YOU-HAVE-IT-DOWNLOADED\MouseWithoutBordersSetup.msi" /l*vx "WHERE-YOU-HAVE-IT-DOWNLOADED\MWoB_Install_Log.txt"

More information on Windows Installer - http://msdn.microsoft.com/en-us/libra...

Btw, please tell us more on your configuration: OS version, etc..
Photo of SnapJag

SnapJag

  • 6 Posts
  • 1 Reply Like
I had a problem installing too. Had to to Enable the Firewall service. It worked for me. Happy now.
Photo of Antoine Martin

Antoine Martin

  • 1 Post
  • 0 Reply Likes
Hello,
I discoverd this software and I tried it This morning.
My config: 1 desktop Dell 32Bit Windows 7
1 laptop Compaq 32 bit Windows 8.
Install sof on the 2 machines.
The soft works perfectly, no problem.
I can use mouse and Keyboard for the 2 machines.

Thank to the developpers.
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
Thanks! And make sure you run the latest version at http://aka.ms/mmrc