Private Builds

  • 2
  • Praise
  • Updated 7 years ago
Private builds of recent fixes to let users do self-hosting...
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
  • excited

Posted 8 years ago

  • 2
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
--- LATEST VERSION ON TOP ---
NOTE: The same version must be run in all machines.
----------------------------------------------------------------------------------

Download Version 2.1.2.0408:

  • Support Windows Phone 7 - More information

  • Per machine installation, shortcut created for all users.

  • Bug fix: Mouse jumps to center screen when hitting 'L'

  • Bug fix: When a machine is behind a different router, keyboard/mouse
    only works one direction.

  • Bind to network adapter instead of IP Address.



Version 2.1.1.1221:

  • Compatible with .Net 4.0, MWB runs on .Net 4 when it is available in the machine, Windows 8 users do not have to enable .Net 2.0.

  • User can hold Ctrl key and move mouse to switch to other machines when Easy Mouse is disabled.

  • Support logging

  • Support CAD simulation (Windows 7 and Windows 2008 Server R2 only)



Version 2.1.1.1010:

  • Bug fix: Mouse speed differs in X and Y directions with a remote machine having multiple monitors or different screen orientation.

  • Hotkey to toggle Easy mouse.

  • Bug fix: Font 'Segoe UI' does not support style 'Regular'.

  • Bug fix: Mouse without Borders is not set to start as Local System account in some XP machines.

  • Option to center mouse cursor when switching machine.

  • Desktop shortcut.

  • Bug fix: Mouse jumps when "Automatically move pointer to the default button in a dialog box" is set.

  • Bug fix: The app does not work with .NET 2.0 version lower than SP2.



And some other minor bug fixes.
Photo of Jerry

Jerry

  • 1 Post
  • 0 Reply Likes
Download link dead!!!
Photo of Obliterator

Obliterator

  • 1 Post
  • 0 Reply Likes
just one bug; occaisionnaly the mouse 'fights me' - i.e. as I move the mouse up the mouse cursor moves up briefly but then counters my movement and moves back down (sometimes slightly more down than I started at). the more I move up, the more it moves down. this only happens occaisionally - and never seems to affect movement in other directions. resolution is simple; move the mouse off the screen onto the other computer and back again - it then works normally again. I'm using the relative mouse option in the latest build which has really improved the frequency with which the problem occurs - but doesn't resolve it completely. would love to see a proper fix for this issue.
invaluable tool though, thanks.
Photo of Warren Kerr

Warren Kerr

  • 2 Posts
  • 0 Reply Likes
I agree, this happens to me too. It's irregular and the workaround is relatively painless.
Photo of azsyndicate

azsyndicate

  • 5 Posts
  • 2 Reply Likes
Ability to Hotkey Easy mouse is great. Thank you!
Photo of briandwall

briandwall

  • 2 Posts
  • 0 Reply Likes
This version fixed an issue I was having with my second PC (an Acer laptop on Vista networked with a Dell desktop on XP with dual screens). When using the mouse on my Dell, when I moved the mouse to the laptop screen, the mouse cursor would jump to the bottom-right corner of the laptop monitor and get stuck there. I no longer have this problem and the program has been working really well.

What a great tool! Thank you!
Photo of Stephen

Stephen

  • 6 Posts
  • 0 Reply Likes
I'd very much like to try this new build, but my office firewall prevents me from accessing file-hosting sites like YouSendIt. Is there any other way you can deliver these builds?

EDIT: I managed to get my hands on a copy. This new version works great, and solves my only major issue with the program. Awesome work!
Photo of Ken

Ken

  • 3 Posts
  • 0 Reply Likes
Hello:

I have installed v2.1.1.1010 and I have noticed increased misdirection of cursor movement than the official build. To help explain the issue, computer1 (c1) has a dual monitor setup with 2 on the left and 1 on the right. Computer 2 (c2) has it's single monitor on the far left hence it could be described as: 2 (c1) : 1 (c1) : 1 (c2)

Tracking the mouse between the 1 (c1) : 1 (c2) boarder gives cursor jump occasionally to 2 (c1) instead of tracking to 1 (c1). Both computers are idential machines with identical resolution.

I hope that helps.

Ken
Photo of Paul Louthan

Paul Louthan

  • 1 Post
  • 0 Reply Likes
I am excited to see that a bug I found (Mouse speed differs in X and Y directions with a remote machine having multiple monitors... ) has apparently already been fixed in this build. I will install and test this asap. Thanks doods.
Photo of hydronics

hydronics

  • 2 Posts
  • 0 Reply Likes
In this new build when I have my laptop away from my desk, the mouse gets stuck when it goes near the left side (the side where it would normally jump to the desktop machine) of the screen. The only way to unstick the curser (when I say stuck, I mean the mouse arrow stops at a random spot and stops responding to all mouse inputs: movement or clicks) is to press escape or alt+tab or the windows key or some other keystroke combination that causes the window to change, and then the mouse comes unstuck.

This wasn't a problem on the previous build, I upgraded because I was having trouble with the mouse jumping to the top right corner of my desktop machine.
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
Did you check the option "Move mouse relatively"? You should not check this option if you do not have a need.
If the option is checked then there would be a timeout before the mouse can come back to the host machine when the machines are disconnected.

The workaround would be to use the hotkey to switch to multiple mode to bring the mouse back, default hotkey for this is pressing the Ctrl key 3 times.
Photo of hydronics

hydronics

  • 2 Posts
  • 0 Reply Likes
No, this is happening with "Move mouse relatively" turned off. It happens on both the desktop if the laptop is turned off or not available and on the laptop if it is away from the desktop. You are right that the hotkey fixes this on both machines but it's definitely a bug that in this build the software doesn't seem to properly see anymore when the other machine is and is not available.
Photo of briandwall

briandwall

  • 2 Posts
  • 0 Reply Likes
I have the same experience but find it a minor frustration. Ctrl key 3 times seems to be a good workaround. Of course a bug fix would be ideal.
Photo of Ken

Ken

  • 3 Posts
  • 0 Reply Likes
Hello All:

I am still running build v2.1.1.1010 and I can confirm the issue described above with random cursor jump is CORRECTED by simply activating (check mark in the box) for "Move Mouse Relatively". I actually never knew of this function until someone posted it in this forum. If you hover over this box, it does describe it should be turned on for computers using a multi-screen (as is my case that is described above). Thanks for your input/comments.

Ken
Photo of jim

jim

  • 16 Posts
  • 0 Reply Likes
I'm using build 2.1.1.1112.
two machines connect both directions and the third machine connects to the other two but does not receive connections.
Any ideas? Is there a way that I can generate a log?
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
Just click on the system tray menu item:
Photo of jim

jim

  • 16 Posts
  • 0 Reply Likes
OK, I just downloaded the latest version ...2.1.1.1112: from http://blogs.technet.com/b/next/archi...
It does not have 'generate log' on it.
The 2.1.1.1112: link listed in the first post on this page goes to yousendit.com
and does have 'generate log'.
shall I post the log here?
Photo of jim

jim

  • 16 Posts
  • 0 Reply Likes
is it safe to have my log info available to the world? Is there a way that someone could somehow hack into my machines with this info?
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
There are only Machine Name and IPs and normally IPs are private. You can open in notepad and do a Ctrl+H to replace them by something readable.
Photo of jim

jim

  • 16 Posts
  • 0 Reply Likes
I changed the machine names but there are a lot of IP addresses. Do you need those or can I replace them or delete them? Maybe it would be easier if I emailed the log to you privately just to be safe?
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
It would works too, my email: DoDucTruong@hotmail.com; Truong2D@gmail.com
Photo of jim

jim

  • 16 Posts
  • 0 Reply Likes
SOLVED:
After your great help we discovered the problem.
I just had to hit the 'clear' button under settings.
Works perfectly! I love this software!
Photo of Henrik

Henrik

  • 8 Posts
  • 0 Reply Likes
If i download ths, it sill says 2.1.0.9
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
I guess you need to go to Internet explore options and clear the cache...
Photo of Henrik

Henrik

  • 8 Posts
  • 0 Reply Likes
It was the installer cach.
When wil the Ctrl+alt+Del change option be available?
Photo of Henrik

Henrik

  • 8 Posts
  • 0 Reply Likes
After the new build1221, i cant move the mouse "throught the monitor" over to the slave pc.
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
We did not make any change related to that feature, did you change any setting in your machine (like the Two Row option)? Did you use the same version in all machines? You can restart the app in both machines, repro the issue and get the log and send to me so I can take a look (email address listed above). Thanks!
Photo of Henrik

Henrik

  • 8 Posts
  • 0 Reply Likes
I have click the Two ROw Again and restartetd the App, but no luck. And it is the same version. I will emil you the log now.
Photo of jim

jim

  • 16 Posts
  • 0 Reply Likes
@Henrik,
thanks to Truong's help. the following works for me:
1. right click the tray icon > About > and ensure all machines have the same version
2 right click on the tray icon and exit MWOB on all machines
3. restart MWOB on all machines
4. right click > options > hit the 'Clear' button on all machines
(you'll need to re-enter the info of the machines)
Photo of Henrik

Henrik

  • 8 Posts
  • 0 Reply Likes
Hey.
It did not help.
But when i start the program, it wan't my admin account. I thought it would work without it..
Photo of jim

jim

  • 16 Posts
  • 0 Reply Likes
1. same on each machine (it's easy to get confused between 1221 and 2112)
2. toggle easy mouse ctrl+alt+E makes it so your cursor requires ctrl+mouse to get on to other machines.
3. make sure all machines are wired (when undock my tablet it goes wireless... when I dock it back again I need to disable wireless so it will use wired again)
Photo of Scott Lepsch

Scott Lepsch

  • 2 Posts
  • 0 Reply Likes
Using version 2.1.1.1112 on two machines, and getting issues lately:

* Occasionally, keyboard focus is split between the two computers. Non-"normal" keys (enter, backspace, etc) will work on the slave where the focus is, but "normal" keys (letters / numbers) will still type on the main computer.

* Reconnection has been very spotty, especially after sleep mode.

* Sometimes the second computer will just stop working, and I have to go into the main computer's MWB settings to uncheck / recheck the second computer to get it to work again.
Photo of Ken

Ken

  • 3 Posts
  • 0 Reply Likes
Hello:

I am finding build v2.1.1.1221 as being the most unstable from all releases. The login process is very flaky (I have 2 machines, both go to sleep at night). When I login every morning I find that the keyboard is flaky accepting some keystrokes, but not others. It is certain chacters that simply fail accept input on 1 computer. The second computer works just fine. I find I need to reboot both computers to get things stable. I though it maybe the keyboard/macros - so I disabled them - but the problem stil persists. I am going to downgrade to the regular release until this is resolved.
Photo of jim

jim

  • 16 Posts
  • 0 Reply Likes
@Ken, instead of rebooting try to exit then hit the 'clear' button. Then hit ctrl+alt+R on each machine. You can also run this in a cmd window in both machines to refresh DNS:

ipconfig /flushdns
ipconfig /registerdns
Photo of AnthonyDa

AnthonyDa

  • 3 Posts
  • 0 Reply Likes
IS this project dead? No new build since months :(
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
The project is internal so you never know what is going on with the project:) The latest build (link above) was just out weeks ago, thanks!
Photo of AnthonyDa

AnthonyDa

  • 3 Posts
  • 0 Reply Likes
My bad then, but Version 2.1.1.1221 is really old..
Photo of mdalban

mdalban

  • 2 Posts
  • 0 Reply Likes
The install can't find .net 4, while I installed the full version of .net 4, is .net 4 client profile an issue?
Working with windows 7 enterprise 64
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
Win7 has .Net2.0 by default so if you do not install .net 4 then you would still be able to install the app, there may be something misconfigured in your machine. You can run regedit and export the data under: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP so I can help take a look...
Photo of mdalban

mdalban

  • 2 Posts
  • 0 Reply Likes
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
I still believe there is something "special" in your machine. You can use the following steps as a workaround, run in an elevated cmd windows:
(remove (x86) if the machine is 32bit OS)

msiexec /a "PathTo MouseWithoutBordersSetup.msi" /qb TARGETDIR="%programfiles(x86)%"

sc create MouseWithoutBordersSvc binPath= "%programfiles(x86)%\Microsoft Garage\Mouse without Borders\MouseWithoutBordersSvc.exe" start= auto DisplayName= "Mouse Without Borders Service"

You can now create a shortcut to the app MouseWithoutBorders.exe

Thanks!
Photo of npitts116x

npitts116x

  • 2 Posts
  • 0 Reply Likes
I'm trying to download the latest build of MWB, 2.1.2.0330, but after installation the reported version number is still 2.1.0.9. I've performed a full uninstall of 2.1.0.9, install the "new" build of MWB via the link above, but still get 2.1.0.9 as the version number after the install...is the link incorrect?
Photo of npitts116x

npitts116x

  • 2 Posts
  • 0 Reply Likes
Nevermind, I see the updated version number is in Programs and Features. You can delete this comment thread.
Photo of Warren Kerr

Warren Kerr

  • 2 Posts
  • 0 Reply Likes
I have a fixed workstation and a laptop connected via MWB (both have static IPs) - all generally works well until I undock the laptop, participate in a meeting (and reconnect to the network elsewhere - maybe even RDP to the workstation) then return to my desk and redock the laptop. The MWB on the fixed workstation complains that the port is already in use and refuses to rebind. Only the (heavily used) copy-paste feature seems to the impacted - I can continue to use the keyb/mouse.
This happens for me even with adapter binding in the newer build 2.1.2.0408.
To correct the issue I need to kill and restart MWB on the workstation (which means finding the old mouse/keyboard! :)).
I think the last build was particularly challenging because for some reason each time I typed the letter "l" on the workstation it would lock the machine (effectively the shortcut Windows-L) - I disabled the Windows key to try to correct the issue but I've since found that 2.1.2 seems to have addressed the problem.
Other than that the product is simply brilliant..
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes
The latest version is now at - https://getsatisfaction.com/mouse_wit...